Android issue for Qt5.3 - compiles fine but cannot run (runs fine on Qt5.1 though)



  • Hi,

    I have a subdirs project developed in Qt5.1, which works as expected for android. I have downloaded the latest beta version of Qt5.3 to test if my project also works here, but unfortunately it gives me quite some problems.
    I have tested on 2 android devices and my project compiles without errors on both but I am not able to execute it on any of them:
    The first is running 4.2 and it just gives me the error message "Unfortunately, xxx has stopped". I have tried to start a debug session with a breakpoint on the first line in the main action, but I still just get the same error message, so I am a bit confused on how to proceed on the debugging - any ideas????
    The second one is running 4.3 and this behaves a little differently. My project uses QML and in this case the execution fails on qobject_cast operation which returns 0, which breaks my code and never loads my QML code:
    @
    QmlUiModule::QmlUi *qmlUi = qobject_cast<QmlUiModule::QmlUi *>(playerFactory->currentPluginObject());
    if (qmlUi)
    qmlUi->loadQml();
    @
    As said, when compiling with Qt5.1 I have none of the above problems and I am a bit lost as I am not sure how to debug these issues.

    Any ideas how I proceed???



  • I have looked at compiled libs compared to when using Qt5.1.
    I get something lile this from the compile messages:
    @Skipping lib/libQt5MultimediaQuick_p.so due to unmet dependencies: lib/libQt5Quick.so,lib/libQt5Qml.so@
    and surely enough I can see that libQt5Qml.so is missing, which I find a little strange as I'm using QML in my application.
    It seems to me that Qt5.3 only picks out the libs required for the application, whereas Qt5.1 includes all the Qt5 libs. Not sure if that is correctly understood. But in this case it seems to me that it miss out the QML lib and I guess that is (at least one reason) why my application fails??? Any ideas about this??? I am a bit clueless how to proceed, so any help is appreciated.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.