Can't start iOS simulator from QtCreator 3.0.1



  • Hi everybody,

    I'm testing mobile development with Qt 5.2.1 and QtCreator 3.0.1 and I'm getting problems to launch my app with the iOS Simulator.
    It compiles fine, but the simulator doesn't launch and I get the follow error message: "error loading iPhoneSimulatorRemoteClient".
    I tried to build and run it on Xcode and the simulator works fine...

    Does anybody have an idea of how to solve this issue?

    Thanks



  • I got the same error after the XCode update to 5.1



  • Could be the same.
    Updated to 5.1 and getting this execution error.

    The generated xcode project still loads, compiles and runs fine in the simulator.



  • Solution which helped me:

    There is already a fix present to support Xcode 5.1 in the official GIT repo (https://qt.gitorious.org/qt-creator)

    Summary:

    1. Rename current QT-Creator for older Xcode versions.
    2. clone qt-creator.git and checkout the corresponding tag.
    3. Compile Qt-Creator and copy product into the original location.
    4. Reimport kits into project.
    5. Build and run.


  • Thanks Bowibit for your beginning of solution.

    If you don't want to handle the compilation of QtCreator you can also directly download a nightly build from here : http://download.qt-project.org/snapshots/qtcreator/

    Can you just tell me how do you reimport kits? The new QtCreator can't auto-detect my Android and iOS kits?



  • Hello All!

    I have the same problem. I'm searching in the whole internet for a solution, but I didn't find yet.

    Bowibit, your link returns a 404....

    If anybody has a solution....


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.