Qt Creator needs a compiler set up to build. Configure a compiler in the kit options. Mac OS 10.9 Qt creator 5.2.1



  • I have just installed Qt Creator 5.2.1 on Mac OS 10.9 (Mavericks) and when I try to build a project I get the next message

    :-1: error: Qt Creator needs a compiler set up to build. Configure a compiler in the kit options.

    I have reinstalled Xcode but still not working.

    I hope you could help me.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You should install the command line tools.

    Go to Preferences -> Downloads -> Components


  • Moderators

    You probably need Xcode + the Command Line Tools (open Xcode, go to Preferences->Downloads).

    Then in Qt Creator, you may need to point it to the compiler, in Tools->Preferences->Build & Run.



  • Have I to do that in Xcode or in QtCreator???

    Sorry I am new in this.

    thank you




  • Moderators

    Then point Qt Creator to your Xcode binary, maybe that would work. I don't actually remember how I made it work, and I don't have a mac here to check.



  • I am installing the Command Line Tools but I don't know what you mean with "Then point Qt Creator to your Xcode binary"

    thanks



  • I have downloaded and installed the Command Line Tools but it is still not working


  • Lifetime Qt Champion

    Did you restart Qt Creator after installing the command line tools ?



  • Yes I did, but the problem is that I am not sure if command line tools was fine installed, it doesn't appear in components of Xcode


  • Moderators

    Open the terminal and type:
    @
    clang --version
    @

    If it prints the version, it means the command line tools are installed and working. Then type that:
    @
    which clang
    @

    And remember the path. Open Qt Creator, go to Preferences->Build & Run->Compilers and see if it is there. if not, add it by hand using the button on the right-hand side.

    Once you have the compiler, you need to set a Qt Creat "Kit": that is a pair of compiler + Qt version. Just switch to the "Kits" tab and add a new one (first check if there are any available already).

    Then you need to configure your project to use your new kit. There are many ways to do it, but in general you should open your project, go to "Project" pane, and add your newly created kit there.



  • I have done this but I still get the next:

    08:35:04: Running steps for project tp1...
    08:35:04: Starting: "/Users/paladoxdoo1/Qt5.2.1/5.2.1/clang_64/bin/qmake" /Users/paladoxdoo1/Desktop/Télécom/IHM/tp1/tp1.pro -r -spec macx-g++ CONFIG+=debug CONFIG+=x86_64 CONFIG+=declarative_debug CONFIG+=qml_debug
    Cannot find file: /Users/paladoxdoo1/Desktop/Télécom/IHM/tp1/tp1.pro.
    08:35:04: The process "/Users/paladoxdoo1/Qt5.2.1/5.2.1/clang_64/bin/qmake" exited with code 2.
    Error while building/deploying project tp1 (kit: Unnamed)
    When executing step 'qmake'
    08:35:04: Elapsed time: 00:00.



  • Thank you so much, Qt is already compiling, but only when I try in new projects, if I open a project that I have worked in other computer it doesn't compiles, it shows me the message in the last post, but now I can work. Thank you :)


  • Lifetime Qt Champion

    If you are opening a project configured on another computer you might have a myproject.pro.user file that might not be usable on your computer.

    Close the project, remove that file and open your project again to reconfigure it.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.