INSTALLING ON MAC 10.6.8



  • Hi All.
    I'm installing QT 5.2.1 on a MAC running 10.6.8. All components are checked - clang 64-bit, Source Components, Tools

    During the process, I get a dialog box stating "Error during installation process (qt.521.clang_64.essentials): Command install_name_tool_failed. Arguments: - Change" followed by a bunch of paths

    When I launch QT, create a project and run it (with default code), I get a yellow dialog with: "Using Qt Quick 1 code model instead of Qt Quick 2. (M324) (3:1)"

    Has anyone experienced this?

    Any advice is appreciated.

    • J


  • It's tricky with 10.6.8. You sure you cannot upgrade to Mountain Lion or Mavericks?



  • Hi hsk...
    I'm working on a company computer, and I'm not sure if they want to upgrade this machine...apparently they are experiencing issues with Mountain Lion and Mavricks...


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What version of Xcode have you installed ?



  • Thanks devnet.

    I'm running Version 3.2.6 (1761)


  • Lifetime Qt Champion

    A bit old…

    Also, can you show an example to the error message you got while installing ?



  • Certainly...

    The component installation dialog box:
    !http://engineeredvisions.com/qt/Components.gif!

    The error during installation:
    !http://engineeredvisions.com/qt/Error.gif!

    And the error when doing the first run/execution:
    !http://engineeredvisions.com/qt/GoToError.gif!

    Should I upgrade my Xcode immediately?

    Thanks again,


  • Lifetime Qt Champion

    Just remembered something: installing 5.2 and onward might have been dropped for 10.6 (however you can still create application that will run on 10.6)

    What you can do if you can't update your OS, is to build Qt 5.2 directly on 10.6, AFAIK that is still supported.



  • SGait,
    Which older version should I install, if 5.2 is not accepted on my system? - J


  • Lifetime Qt Champion

    IIRC the latest in the 5.1 series

    But you should really consider building 5.2, it's not really that hard on OS X and depending on your needs, you don't have to build every module



  • I'd love to, SGaist. I just can get past these errors during installation and run :(


  • Lifetime Qt Champion

    Then just download Qt Creator, and the 5.2.1 sources from there you should be able to build Qt and use it in Qt Creator (after the usual configuration steps for add a new Qt version)



  • I get the same error doing a vanilla install on 10.6.8 . :

    Error during installation process (qt.521.clang_64.essentials):
    Command install_name_tool failed.
    Arguments: -id /Users/jdp/Qt5.2.1/5.2.1/clang_64/lib/QtHelp.framework/Versions/5/QtHelp /Users/jdp/Qt5.2.1/5.2.1/clang_64/lib/QtHelp.framework/Versions/5/QtHelp
    Output:

    This happens twice. I ignore it and the app installs.

    There are no example projects available from the GUI.

    I am able to create a new project. Whenever I do anything, I get:

    :-1: error: The Qt version is invalid: Qt version is not properly installed, please run make install

    This is not a very helpful message. I did not download the source.

    Hey guys, this really should work out of the box. If this version does not work for 10.6.8, you should state that somewhere; usually there is a system requirements link. I couldn't find one on your site.

    For the record, Lion and Mountain Lion don't support multiple monitors very well and I'm not ready for Mavericks.

    Please explain how to get this working.
    --Jim



  • Update your Xcode to 4.2 (it's free) it works on Snow Leopard 10.6.8.
    I think Xcode 3.2.6 prefers gcc compiler, but Qt prefers clang.
    Xcode 4.2 has a much better clang support.



  • Thanks for the quick reply.

    I am using Xcode 4.2. Why does this matter? Is Qt using Xcode somehow?

    What about the "install_name_tool failed" message? Isn't that a bug in the Qt installer? Could that explain the "Qt version is invalid" problem? Or are these two separate problems?
    --Jim



  • Aha, sorry I thought you were still using Xcode 3.2.6 (1761).
    Also check that you have installed the command line tools for Xcode.



  • I think I did a full install of Xcode. How do I check for command line tools?



  • Easiest might be just to install them anyway:
    Inside Xcode, Preferences Downloads, look in "more downloads", log in to Apple and choose "Command line tools for Xcode".

    Also start a Terminal and type install_name_tool to see that it starts ok.



  • I don't see command line tools for Xcode under preferences: downloads tab.
    install_name_tool appears to be there. I get the following in the Terminal:

    MacMini:~ jdp$ install_name_tool
    Usage: install_name_tool [-change old new] ... [-rpath old new] ... [-add_rpath new] ... [-delete_rpath old] ... [-id name] input



  • install_name_tool ok, good.
    About command line tools for Xcode 4.2, it seems there is no separate package for it, sorry! They're supposed to be installed together with Xcode, and should be installed at /Developer/usr/bin or /usr/bin.



  • They appear to be at /Developer/usr/bin.

    What does this have to do with Qt?



  • Qt needs a compiler and a toolchain, for Macs that's Xcode and the other tools.



  • I think all that stuff is there. So Qt has a bad path from the installer?

    Can I point it at the compiler and tool chain manually somehow?



  • Yeah, go inside QtCreator, Preferences, Build & Run, select the Kits tab. Under Auto-detected you should see "Desktop Qt 5.2.1 clang 64bit".
    Check that the Compiler field is set, otherwise click Manage...



  • This totally did not work . I tried setting the compiler and the version.

    I finally uninstalled 5.2.1 and Qt Creator 3.0.1. I then installed Qt 4.8.5, Qt Debug Libraries 4.8.5, and Qt Creator 2.8.1. I had to go to archives to find Qt Creator 2.8.1. It did not work out of the box.

    I had to do the following:

    Launch Qt Creator 2.8.1 .
    Select Qt Creator-> Preferences, then Build & Run tab.
    Select Qt Versions tab.
    Select qmake location: Choose...
    Navigate from the Applications folder to /Developer/Tools/Qt/qmake
    Select the Kits tab.
    Select Clang 64bit.
    Select Qt Version: Manage ...
    Select Qt 4.8.5.
    Repeat the last 3 steps for GCC 64bit.
    I think I may have had to select "Auto-detect" on the debugger.

    Why doesn't Qt Creator know or find where qmake is?


  • Lifetime Qt Champion

    Because there is no single place for qmake especially if you have several version Qt installed (e.g. Qt 5, Qt 4, Qt for Android etc…)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.