Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Deploy Qt3D project for Android under win 7



  • I've successfully deployed the cube example APK by creating a new Quick 2 project and copy qml file there, but got "module "Qt3D" plugin "qthreedqmlplugin" not found" error message, any clue for this? I already place the so file into imports/Qt3D folder, but no success. Thanks.

    Edit: I tried using Qt 5.1.1 and followed the Qt3D installation described here (http://qt-project.org/wiki/Qt3D-Installation) , and can get rid of the plugin not found error message above. But, this time, a message of "library "libQt53DQuick.so" not found" show up as follows:
    @W/Qt (29930): assets:/qml/3dCube/main.qml:2 (): assets:/qml/3dCube/main.qml:2:1: plugin cannot be loaded for module "Qt3D": Cannot load library /data/data/org.qtproject.example.test3D/qml/Qt3D/libqthreedqmlplugin.so: (Cannot load library: soinfo_link_image(linker.cpp:1635): could not load library "libQt53DQuick.so" needed by "libqthreedqmlplugin.so"; caused by load_library(linker.cpp:745): library "libQt53DQuick.so" not found) @



  • I've solved the problem by adding this line into my .pro file as follows:
    QT += qml quick 3dquick

    But as I tried the Qt3D animation example, when using mesh property to load the dae file in Item3D, the app died with the following message shown:

    D/skia (18886): Flag is not 10
    F/libc (18886): Fatal signal 11 (SIGSEGV) at 0x00008892 (code=1), thread 18909 (QSGRenderThread)

    I'm using Qt5.2.1 and wondering somebody had the experience can help here. Thanks.


Log in to reply