Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt 5.2.1 fails to build on OS X



  • Although configure seems to work perfectly, running make results in errors almost immediately:

    Project WARNING: You should probably load(qt_build_config) first in bootstrap.pro for QtBootstrap, as the latter also load()s qt_module.
    Project MESSAGE: Not doing so may lead to qt_module.prf overriding compiler/linker options in your .pro file.
    Project MESSAGE: Ignore this warning with CONFIG+=no_qt_module_warning if you know what you are doing.
    Project ERROR: Module does not define version.
    make[2]: *** [sub-bootstrap-make_first] Error 3
    make[1]: *** [sub-src-make_first] Error 2
    make: *** [module-qtbase-make_first] Error 2

    I'm running this on OS X 10.8.5 with XCode 5.0 installed.
    Options to configure were the following: -opensource -arch x86_64 -debug-and-release -no-framework -confirm-license

    Has anyone successfully built Qt 5.2.1 from source on OS X?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Which source did you use ? Git ? Package ? If the later, zip or tar.bz2 ?





  • One thing that i notice is the use of the -arch switch. In Qt5 that switch is ignored and has been replaced with -platform. That probably isn't the cause of your problem, but I thought I would let you know.



  • I just built qt 5.2.1 with the following configure. I know its not the same, but this configuration worked.

    @
    /configure -debug-and-release -nomake examples -nomake tests -platform macx-clang-32 -skip qtwebkit -skip qtwebkit-examples
    @



  • Any reason you want '-no-framework' ? I built it on many different machines with similar config, except for that one.



  • I've changed my configure options to

    configure -opensource -debug-and-release -nomake examples -nomake tests -skip qtwebkit-examples -no-framework -confirm-license

    but still no luck. I can't skip qtwebkit as I need webkit. As for the no-framework: it has a reason but I can't remember what it was and removing that option doesn't make a difference; the error still occurs.



  • Are you running just make or make -j(some number)?



  • [quote author="steno" date="1392824203"]Are you running just make or make -j(some number)?[/quote]

    I've tried both "make -j9" and simply "make" with no difference.

    Is there some way to raise the verbosity of the build process? (I tried "make -d" but that generates output for debugging make)
    Or another way to pinpoint the source of the problem?

    For info: Qt 4.8.4 is installed (built from source and then installed using "make install") in /usr/local/Trolltech/Qt-4.8.4 but that shouldn't make a difference.



  • All I can think of is that you have non standard tools in your PATH (macports, fink, etc) or you are not building from a clean source tree (and make confclean does not give you a clean source tree, delete and extract the tar.gz again).

    Like I said, I've build Qt5.2.1, with latest OS and latest Xcode many times.



  • [quote author="sandy.martel" date="1392893567"]All I can think of is that you have non standard tools in your PATH (macports, fink, etc) or you are not building from a clean source tree (and make confclean does not give you a clean source tree, delete and extract the tar.gz again).

    Like I said, I've build Qt5.2.1, with latest OS and latest Xcode many times.[/quote]

    I've deleted my entire source tree several times already, so that can't be the cause.

    I don't remember installing either fink or macports. How do I check if one of those is installed? Btw wouldn't that generate problems when building other code as well?



  • I tried to build on a dedicated build machine which has no software installed except OS X 10.8.5, XCode 5.0, cmake 2.8.8, TextWrangler and perforce client tools and the same error occurs.



  • It's now building at last (let's hope it finishes successfully).

    It appears some files were missing after all: the hidden files (like .qmake.conf) didn't make it into my cvs and as such didn't make it to my build folder.


Log in to reply