QT Creator won't recognize my .pro file in v2.7.2



  • I am new to a team that uses QT Creaor for development and they have a .pro file for the project. I have been unable to import the project file into qt creator. I have also been unable to find any info on this while searching the web.



  • Is there any error message in the output after parsing the .pro file?



  • No, it just doesn't offer the option of importing it as a project. I'm pretty new to using qt creator so it might be easy to fix but I have not found out how yet. So far I have tried:

    1. On the welcome screen click open project. No option for .pro file
    2. File ->Open File or Project: Select projectname.pro and it opens it as a text file.

    Also, my coworker is also using 2.7.2 and doesn't seem to have this problem.


  • Moderators

    welcome to devnet

    Which OS are you on?
    The file dialog should give you the option to navigate to the folder with the .pro file and list it when you have opened the folder.



  • Ubuntu 12.04 LTS


  • Moderators

    The only thing I see is that you are trying to open the .pro.user file. Typically you have a file "MyProjectName.pro" which is the project file. When opened Qt creator creates aside a "MyProjectName.pro.user". This file contain some settings. This happened a number of times to me when opening a project on windows. There the last extension is cut off. So in the menu you see a file named "MyProjectName" and a file "MyProjectName.pro". However, AFAIK you do not have this confusing problem on Ubuntu. Anyway, you can limited the files displayed with the filter setting in the combobox on the right. Use "Qt Project file (*.pro)". Now only project files are shown.



  • I don't have the Use "Qt Project file(*.pro) option.

    This has been very bizarre. Its like Qt Creator has alzheimer's and doesn't know who it is anymore.

    BTW, I also tried installing 2.8 and had the same issue. Should I have a certain version of Qt installed too?


  • Lifetime Qt Champion

    Hi,

    It depends on how you installed Qt. Go to Preferences -> Build & Run -> Qt Versions. You'll see there what version is detected. If none, just add yours then make a Kit with it



  • I get a Qmake not executable error


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.