Qt Creator 3.0.0 and Ctrl-Shift under X.Org X Server 1.15.0



  • I'm running Arch Linux with X.Org server 1.15.0 and I have Qt Creator 3.0.0 with Qt 5.2.0 installed from Arch repo.
    I'm using Awesome window manager.
    I'm using the following Xorg keyboard configuration:
    @Section "InputClass"
    Identifier "system-keyboard"
    MatchIsKeyboard "on"
    Option "XkbLayout" "us,ru"
    Option "XkbVariant" ","
    Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll,compose:rwin"
    EndSection
    @
    The problem is the following: whenever I use ctrl+shift to change keyboard layout, Qt creator loses the first key I press.
    For example, if i keep pressing the same key (for example, "G") twice then switch layout, press it twice again, switch, press, etc., I get "пgпgпgпg" instead of "ппggппggппggппgg", because every key right afrer layout change is "eaten".

    I've found the following: this happens if "grp:ctrl_shift_toggle" was set during Qt Creator startup. If it's started, and then I switch layout change to Alt+Shift:
    @setxkbmap -option -option grp:alt_shift_toggle
    @
    then Qt Creator still "eats up" the first key after Ctrl+Shift released.
    If Qt creator is started with "grp:with alt_shift_toggle" or with no toggle at all, everything is fine even if I switch to "grp:ctrl_shift_toggle" after it's start.

    The problem doesn't seem to appear in Gnome DE, as long as it uses his own layout management routine, but I don't like new gnome, so I decided to stay in Awesome.
    Any other app works fine.
    Awesome doesn't use any "Ctrl+Shift+KEY" sequences. All his shortcuts involve a key with a logo between Ctrl and Alt.

    I'm not sure if this is a bug of Qt creator or my own distro setup, so I've posted it here and not in the bugtracker.



  • I've tried to remove all the hotkeys from Qt Creator that involve Ctrl and Shift together, and still no result.
    Is there anything else about Ctrl+Shift key combo in Creator?



  • Something is really funny...
    Ctrl+Num/ doesn't seem to work, while Ctrl+'/' (where '/' is located on the left from Right Shift key) works.
    This is independant of NumLock or current layout and sometimes is very frustrating.

    EDIT: my current workaround is the following bash script:
    @
    #!/bin/bash
    echo Starting Qt Creator with a keyboard workaround. What a shame :(
    xkb_option=$(setxkbmap -query | grep options | sed 's/options:\s*//')

    setxkbmap -option
    qtcreator &
    #another nasty workaround to make SURE creator has started before setxkbmap returns old layout
    sleep 5
    setxkbmap -option $xkb_option@

    This is obviously an ugly solution :(



  • OK. Brilliant. Now Qt creator is completely unusable.
    With version 3.1.2 my workaround doesn't work anymore. Qt creator keeps eating up the first symbol after Ctrl+Shift language switch. If I change grp:ctrl_shift_toggle to grp:alt_shift_toggle, Ctrl+Shift doesn't produce any bugs but doetn't switch layout as well.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Sounds you might be hitting a bug, did you already checked the "bug report system":http://bugreports.qt-project.org to see if it's something known ?



  • I've reported here:
    https://bugreports.qt-project.org/browse/QTCREATORBUG-9589
    Looks like it's not QtCreator-related bug, but it appears there.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.