Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt 5.2 "Hello World" on iOS -- What am I doing wrong?



  • Hello,

    I wanted to play around with Qt 5.2 on iOS, but it just doesn't seem to work :) I have simply gone through the example in this video: https://www.youtube.com/watch?v=WFGRr0DV3oM

    Everything runs nicely on the desktop. I have the iOS simulator running, but when I try to run in on the simulator I only get a black screen for a few seconds before the app dies. I get the following lines in the system log:

    Jan 26 14:08:25 Plex-Media-Center com.apple.iphonesimulator.launchd.4c6439fd[8695] (UIKitApplication:com.yourcompany.QtMobileTest[0xfb37][8724]) <Notice>: Service exited due to signal: Bus error: 10
    Jan 26 14:08:25 Plex-Media-Center.local backboardd[8697] <Warning>: Application 'UIKitApplication:com.yourcompany.QtMobileTest[0xfb37]' exited abnormally with signal 10: Bus error: 10

    I have tried the same on two different Macs, A MacBook Pro and a Mini, both running Mavericks and Xcode 5.0.2. I've tried different device profiles on the simulator, but none of them work.

    The app is apparently installed on the simulator, since I get an icon for it, but trying to run it from the icon has the same result (immediate crash).

    This should be real straight forward, so I can't really see what I'm doing wrong? Any insight would be greatly appreciated


Log in to reply