Accelbubble example



  • Hello,

    I'm trying the "accelbubble" example to get working. Before that I successfully ran the Hello World Example created with the QtCteator. I'm using my mobile not the emulator

    But trying to run the accelbubble example I'm getting the following error message:

    @Starting remote process.D/AndroidRuntime(31192):
    D/AndroidRuntime(31192): >>>>>> AndroidRuntime START com.android.internal.os.RuntimeInit <<<<<<
    ...
    D/dalvikvm( 1192): Added shared lib /data/data/org.qtproject.example.accelbubble/lib/libgnustl_shared.so 0x424f68c0
    D/dalvikvm( 1192): No JNI_OnLoad found in /data/data/org.qtproject.example.accelbubble/lib/libgnustl_shared.so 0x424f68c0, skipping init
    D/dalvikvm( 1192): Trying to load lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Core.so 0x424f68c0
    D/dalvikvm( 1192): Added shared lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Core.so 0x424f68c0
    D/dalvikvm( 1192): Trying to load lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Network.so 0x424f68c0
    D/dalvikvm( 1192): Added shared lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Network.so 0x424f68c0
    I/Qt ( 1192): Network start
    D/dalvikvm( 1192): Trying to load lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Qml.so 0x424f68c0
    D/dalvikvm( 1192): Added shared lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Qml.so 0x424f68c0
    D/dalvikvm( 1192): No JNI_OnLoad found in /data/data/org.qtproject.example.accelbubble/lib/libQt5Qml.so 0x424f68c0, skipping init
    D/dalvikvm( 1192): Trying to load lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Gui.so 0x424f68c0
    D/dalvikvm( 1192): Added shared lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Gui.so 0x424f68c0
    D/dalvikvm( 1192): No JNI_OnLoad found in /data/data/org.qtproject.example.accelbubble/lib/libQt5Gui.so 0x424f68c0, skipping init
    D/dalvikvm( 1192): Trying to load lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Quick.so 0x424f68c0
    D/dalvikvm( 1192): Added shared lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Quick.so 0x424f68c0
    D/dalvikvm( 1192): No JNI_OnLoad found in /data/data/org.qtproject.example.accelbubble/lib/libQt5Quick.so 0x424f68c0, skipping init
    D/dalvikvm( 1192): Trying to load lib /data/data/org.qtproject.example.accelbubble/lib/libQt5QuickParticles.so 0x424f68c0
    D/dalvikvm( 1192): Added shared lib /data/data/org.qtproject.example.accelbubble/lib/libQt5QuickParticles.so 0x424f68c0
    D/dalvikvm( 1192): No JNI_OnLoad found in /data/data/org.qtproject.example.accelbubble/lib/libQt5QuickParticles.so 0x424f68c0, skipping init
    D/dalvikvm( 1192): Trying to load lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Widgets.so 0x424f68c0
    D/dalvikvm( 1192): Added shared lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Widgets.so 0x424f68c0
    D/dalvikvm( 1192): No JNI_OnLoad found in /data/data/org.qtproject.example.accelbubble/lib/libQt5Widgets.so 0x424f68c0, skipping init
    D/dalvikvm( 1192): Trying to load lib /data/data/org.qtproject.example.accelbubble/plugins/platforms/android/libqtforandroidGL.so 0x424f68c0
    D/dalvikvm( 1192): Added shared lib /data/data/org.qtproject.example.accelbubble/plugins/platforms/android/libqtforandroidGL.so 0x424f68c0
    I/Qt ( 1192): qt start
    W/dalvikvm( 1192): dvmFindClassByName rejecting 'org/qtproject/qt5/android/QtMessageDialogHelper'
    D/dalvikvm( 1192): Trying to load lib /data/data/org.qtproject.example.accelbubble/lib/libQt5QuickParticles.so 0x424f68c0
    D/dalvikvm( 1192): Shared lib '/data/data/org.qtproject.example.accelbubble/lib/libQt5QuickParticles.so' already loaded in same CL 0x424f68c0
    D/dalvikvm( 1192): Trying to load lib /data/data/org.qtproject.example.accelbubble/lib/libaccelbubble.so 0x424f68c0
    D/dalvikvm( 1192): Added shared lib /data/data/org.qtproject.example.accelbubble/lib/libaccelbubble.so 0x424f68c0
    D/dalvikvm( 1192): No JNI_OnLoad found in /data/data/org.qtproject.example.accelbubble/lib/libaccelbubble.so 0x424f68c0, skipping init
    W/Qt ( 1192): kernel/qcoreapplication.cpp:416 (QCoreApplicationPrivate::QCoreApplicationPrivate(int&, char**, uint)): WARNING: QApplication was not created in the main() thread.
    D/dalvikvm( 1192): GC_CONCURRENT freed 467K, 15% free 10585K/12423K, paused 12ms+3ms, total 51ms
    W/dalvikvm( 1192): dvmFindClassByName rejecting 'org/qtproject/qt5/android/QtNativeInputConnection'
    W/dalvikvm( 1192): dvmFindClassByName rejecting 'org/qtproject/qt5/android/QtExtractedText'
    D/libEGL ( 1192): loaded /system/lib/egl/libEGL_mali.so
    D/libEGL ( 1192): loaded /system/lib/egl/libGLESv1_CM_mali.so
    D/libEGL ( 1192): loaded /system/lib/egl/libGLESv2_mali.so
    W/Qt ( 1192): ../accelbubble/qtquick2controlsapplicationviewer/qtquick2controlsapplicationviewer.cpp:84 (void QtQuick2ControlsApplicationViewer::setMainQmlFile(const QString&)): assets:/qml/accelbubble/main.qml:27 module "QtSensors" plugin "declarative_sensors" not found
    W/Qt ( 1192):
    W/Qt ( 1192): qml/qqmlcomponent.cpp:871 (QObject* QQmlComponentPrivate::beginCreate(QQmlContextData*)): QQmlComponent: Component is not ready
    F/Qt ( 1192): ../accelbubble/qtquick2controlsapplicationviewer/qtquick2controlsapplicationviewer.cpp:88 (void QtQuick2ControlsApplicationViewer::setMainQmlFile(const QString&)): Error: Your root item has to be a Window.
    F/libc ( 1192): Fatal signal 11 (SIGSEGV) at 0xdeadbaad (code=1), thread 1208 (ple.accelbubble)

    'org.qtproject.example.accelbubble' died.

    Do you know how to solve the problem? Please notice the "QtSensors" plugin "declarative_sensors" error.

    Regards,
    Jan



  • Hi!

    I had the same problem and I fixed it by making these changes in the QML file:

    @import QtSensors 5.0 as Sensors
    ...
    Sensors.Accelerometer {
    ....
    }
    @

    Here is a link of reference:

    "https://qt-project.org/doc/qt-5/qtsensors-qmlmodule.html":https://qt-project.org/doc/qt-5/qtsensors-qmlmodule.html



  • Hi,

    When I switch from Realease to Debug mode this "module 'QtSensors' plugin 'declarative_sensors' not found"-error is away and the app runs.

    But untfortunatelly I dont understand why. Can you tell me?

    Regards,



  • In Debug mode I can see this in the Compiler output:

    D/dalvikvm(13913): Trying to load lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Svg.so 0x41a87678
    D/dalvikvm(13913): Added shared lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Svg.so 0x41a87678
    D/dalvikvm(13913): No JNI_OnLoad found in /data/data/org.qtproject.example.accelbubble/lib/libQt5Svg.so 0x41a87678, skipping init

    D/dalvikvm(13913): Trying to load lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Xml.so 0x41a87678
    D/dalvikvm(13913): Added shared lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Xml.so 0x41a87678
    D/dalvikvm(13913): No JNI_OnLoad found in /data/data/org.qtproject.example.accelbubble/lib/libQt5Xml.so 0x41a87678, skipping init

    D/dalvikvm(13913): Trying to load lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Sensors.so 0x41a87678
    D/dalvikvm(13913): Added shared lib /data/data/org.qtproject.example.accelbubble/lib/libQt5Sensors.so 0x41a87678
    D/dalvikvm(13913): No JNI_OnLoad found in /data/data/org.qtproject.example.accelbubble/lib/libQt5Sensors.so 0x41a87678, skipping init

    In Release mode I dont see that. The names of these libraries match exactly to those entries I added to the .pro file:

    QT += quick sensors svg xml



  • tks for your post.But what's the real reason?

    [quote author="wind" date="1389575684"]Hi!

    I had the same problem and I fixed it by making these changes in the QML file:

    @import QtSensors 5.0 as Sensors
    ...
    Sensors.Accelerometer {
    ....
    }
    @

    Here is a link of reference:

    "https://qt-project.org/doc/qt-5/qtsensors-qmlmodule.html":https://qt-project.org/doc/qt-5/qtsensors-qmlmodule.html[/quote]


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.