Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Recompiled Qt 4.8.5 (with MinGW 4.8.1) crashes on using NCReport [SOLVED]



  • I had to rebuild Qt with MinGW 4.8.1 because I started using C++11 language features not available in MinGW 4.4 that Qt 4.8.5 was built with.

    Everything worked fine until I started using NCReport which was probably compiled with the same MinGW 4.4. I compile and link my application, but when I create a NCReport object, I get an access violation. I guess this is because my app and the Qt that I use was compiled with MinGW 4.8.1 and NCReport and the Qt it uses were compiled with MinGW 4.4.

    Is this correct?

    I guess I'm buggered then...


  • Lifetime Qt Champion

    Hi,

    Yes it is. But you should ask the guys behind NCReport to ensure which version of MinGW they are using



  • Thanks for the response.

    They have a download for MinGW and Qt 4.8.5, so it seems logical that it was compiled against the standard Qt libraries which was compiled with MinGW 4.4.

    I will have to try the "Contact us" form.

    Somebody is going to shoot me at work...


  • Lifetime Qt Champion

    If you intend to become a customer of NCReport, they might provide you with a version compiled against a newer MinGW



  • I posted a question on their website. I am going to purchase licenses, so the issue is just if the source is supplied and how easy it is to rebuild myself, hopefully no strange dependencies, only Qt. Or if they will provide me with a different version compiled with MinGW 4.8.1.

    Thanks for the response!


Log in to reply