QtMobility 1.1 integration with Qt Creator



  • I have Qt Creator 2.0.1 installed (Qt 4.7.0) and I'm trying to integrate QtMobility 1.1 with the MinGW Simulator tool chain.

    Here's what I did:

    • Extracted QtMobiltity to C:\QtMobility\qt-mobility-symbian-opensource-1.1.0\
    • Added C:\NokiaQtSDK\mingw\bin to my PATH
    • Ran "configure -qt C:\NokiaQtSDK\Simulator\Qt\mingw\bin"

    (NOTE: If I run configure without -qt, instead setting QT_PATH, I get a "\Common was unexpected at this time." and it clears the QT_PATH value)

    The build completes successfully (albeit with some "unescaped backslashes are deprecated" warnings) with the message: configure has finished. You may run mingw32-make to build the project now.

    However, it hasn't actually changed anything in QtCreator and the QtMobility version number (in NokiaQtSDK\Simulator\QtMobility\mingw\include\qmobilityglobal.h) still says 1.0.2

    Any thoughts?



  • I'll leave this post around in case someone else wants to answer it, but I ended up solving it by installing Qt Creator 2.1 RC (which ships with QTM 1.1)



  • For anyone using Qt SDK 1.1 Technical Preview all I had to do was go into the .pro file and uncomment out the
    @
    CONFIG += mobility
    @
    code to enable the mobility 1.1 libraries that come with it.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.