Qt 5.2 iOS error 65



  • Hello,

    I've just installed Qt 5.2 to try the new iOS export features. I compiled some of my projects and also some examples that come by default with Qt 5.2 with the 'desktop' target and everything went very good.

    But when I selected the "iphonesimulator-clang 5.2 for iOS" target, I received an "[iphonesimulator-release] Error 65" error.

    As a side note, I've tried to compile multiple projects and I received the same error. Also, I have Xcode 5.02 installed on my Mac (my Xcode installation does not have any problem when compiling something for iOS).

    Additional information:

    • The compilation output can be found "here":http://pastebin.com/raw.php?i=ndRqyYgN.
    • Xcode builds have no problems.
    • The tested programs compiled successfully using the "Desktop" option.
    • I did not test on a "real" iDevice because I currently don't have an Apple Developer Account.

    The output suggests me that the following files are missing/not found:
    @qglobal.h@
    @qtplugin.h@

    Both errors seem to come from the lines:
    @#include <QtCore/qtglobal.h>@
    @#include <QtPlugin>@

    By the way, the application that I am trying to compile is the "calqlatr" example that comes with the Qt SDK.

    Thanks in advance,
    Alex.



  • I fixed the error long ago, but I preferred to share it for anyone that may experience this error.

    The solution is fairly simple, just ensure that all includes in your project are based on the file location. For example, I have a header located at /src/class/class.h and a source file at /src/class/class.cpp

    Ensure that in the implementation you use something like this:
    @
    #include "chat.h"
    @
    instead of

    @#include "/src/class/class.h"@

    This applies both when you include a class in the declaration and/or in the implementation.

    Hope it helps,
    Alex.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.