Is it possible to statically linking GLIBC_2.xxx



  • Hi,

    I have successfully built QT5.2.0 using the below mentioned cross-compiler delivered by freescale
    @/opt/freescale/usr/local/gcc-4.4.4-glibc-2.11.1-multilib-1.0/arm-fsl-linux-gnueabi/bin/arm-fsl-linux-gnueabi-@

    Everything was going fine until I tried to run my first QT application on the target and I get the following:
    @./quickTest2: /lib/libc.so.6: version GLIBC_2.10' not found (required by /usr/local/qt5/lib/libQt5Network.so.5) ./quickTest2: /lib/libc.so.6: versionGLIBC_2.11' not found (required by /usr/local/qt5/lib/libQt5Gui.so.5)
    ./quickTest2: /lib/libc.so.6: version GLIBC_2.7' not found (required by /usr/local/qt5/lib/libQt5Core.so.5) ./quickTest2: /lib/libc.so.6: versionGLIBC_2.9' not found (required by /usr/local/qt5/lib/libQt5Core.so.5)@

    I investigated some more and it looks like the linux distribution which I am using on my target is build with:
    @/opt/freescale/usr/local/gcc-4.1.2-glibc-2.5-nptl-3/arm-none-linux-gnueabi/bin/arm-none-linux-gnueabi-@

    For various reasons it is not easy for me to cross-compile everything from scratch for the target using the more recent cross-compiler.
    What are my options:

    Can GLIBC be statically linked? (I just copy the headers into target and hope for the best)

    Should I use an older QT which uses GLIBC 2.5? What GLIBC is required for QT 5.0?

    Are there any other options?

    UPDATE:
    I managed to find this official link which states that QT 5 is tested against gcc 4.5 and newer. But it also mentioned that any c++98 compiler should work.
    source: http://qt-project.org/doc/qt-5.0/qtdoc/platform-notes.html



  • Hi, did u manage to resolve this? I'm facing a similar problem...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.