[solved] Strange Crashes/Freezes on some OSX's but not on others..



  • Hi,

    I am trying to make an app run across various OSX systems..
    using Qt 5.2rc on OSX 10.9, as described in this thread:

    http://qt-project.org/forums/viewthread/35861/

    After my problems of opening files seems to be solved, here's the situation:

    it runs fine on the system where it was compiled, which is a OSX 10.9 ...

    it also runs fine on my newly installed partition of 10.9 (which doesn't have xcode or any Qt sdk installed),

    and runs fine on my other newly installed partitions 10.8, 10.7 and a 10.6.8, all on my laptop, a macbook pro from 2011.

    it even runs on a macbook from 2008 with os 10.6

    Alas, on a seperate macbook pro with OSX 10.9 , it crashes with an error message:
    "Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0 libGLU.dylib"

    and on yet another macbook pro from 2011, also with a 10.9 OSX, it freezes, without error message, just displaying the eternal "beach-ball", 100% cpu usage..

    I am puzzled...., since it works fine on all my installed partitions... but not on the other computers..



  • yeah so basically I get crashes or freezes on some constellations with 10.9, but not on at least 2 other 10.9's,

    and so far it worked on all other versions of OSX 10.8 down to 10.6


  • Lifetime Qt Champion

    Hi,

    Can you compare the hardware from the macs where it crashes ?



  • I get a crash with error message on this macbook pro, running on OSX 10.9:
    2,4ghz intel core 2 duo
    nvidia geforce 9600m gt 256 MB RAM

    On another macbook pro OSX 10.9 I get the eternal beachball (no error message), with these hardware details:
    2,2 GHz Intel Core i7
    AMD Radeon HD 6750M 1024 MB

    Finally on my MacBookPro7,1, with OSX 10.9
    Intel Core 2 Duo
    2.66 GHz
    NVIDIA GeForce 320M

    it runs fine.

    My next step would be to again minimize the app, and then gradually expand it until the crashes appear on the mentioned systems. (I have a hunch that this happens when adding OpenGL code, but not sure..)

    If you have any other ideas, please let me know.


  • Lifetime Qt Champion

    That would also be the procedure I would follow. One other thing you can do is also update to the official 5.2



  • Updating to official Qt 5.2 and deploying them with that same release's macdeployqt seems to fix this problem. All the above mentioned systems running mavericks now successfully run my application.

    it didn't work with 5.2 beta, 5.2rc, I think those version's macdeployqt somehow failed at adding or connecting a framework in the .app, although that's guess work.


  • Lifetime Qt Champion

    There's been a lot of work done for Mavericks between the beta and the release


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.