[iOS] Error 65 during compilation



  • Hi,
    I've written an application for android and wanna to check it on iOS but i keep getting error 65 to be exactly ":-1: error: [iphonesimulator-debug] Error 65"

    I think the problem is compiller configuration. There is a screen from it.
    !http://postimg.org/image/adp0s63s3/(Image)!
    Link: "Click!":http://postimg.org/image/adp0s63s3/

    Btw. I got Qt5.2 rc1 bianry version from website with andorid and ios support.

    Thanks in advance.



  • You can try:

    • to use directly Xcode (for do that, just run qmake from the console and it will create an Xcode project)
    • to compile for iOS device instead of simulator


  • Hi,

    I have the similar problem with the latest Qt 5.2 RC1. I took several example projects and cannot build any of them. For example for the chart sample project in Qt Creator I have error 65. When I tried to build it from Xcode initially I had error with every Qt include like QApplication that it cannot find the .h file. I've included the path to Qt headers (like /Users/mykhaylomerkulov/Qt5.2.0/5.2.0-rc1/ios) into the Header Search Paths and now I have another error during build:

    _ld: framework not found Qt5Widgets _

    However, the Qt5Widgets lib is present in the list of linked libraries. I have almost the same problems with other sample projects.

    How can I fix this problem?



  • Hi,
    same situation here. I've downloaded official Qt 5.2 from 12th of December and i can't build any example project for iOS (for MAC platform it builds and runs ok).

    Seems that compiler doesn't see header files :

    /Users/Robert/Qt5.2.0/5.2.0/clang_64/examples/widgets/layouts/basiclayouts/dialog.cpp:41:10: fatal error: 'QtWidgets' file not found
    #include <QtWidgets>

    I tried also to compile project in Xcode but it also failed.

    Do you have any more suggestions? Is anyone here who compiled iOS examples successfully?



  • I also encountered the same problem
    why?



  • Yesterday i've installed Qt 5.2 stable version with newest version of xcode, I didn't try to compile my program for simulator but there is no problem with compiling for real device.



  • Same issue here.



  • I've found nice way to deal with it, just try to compile in Qt and if it fails open XCode and then compile it there. You will get every error printed out.



  • I have the same issue using the download released on December 12 2013.

    I can't believe they released it this way. I tried a few examples tagged with ios and none work:

    ./../diagramscene/diagramitem.h:44:10: fatal error: 'QGraphicsPixmapItem' file not found
    #include <QGraphicsPixmapItem>
    ^
    1 error generated.

    Compiling in xcode is not really a solution, in my mind.



  • You need to use XCode anyway to set screen orientation and icon, so it's not a big problem and for now i would recommend it. The way i see it it just works there.



  • ok, when you open an example you need to do a few things:

    • click on an ios tag. This adds tag:"ios" the search box and only ios compatible apps will be visible.

    • select Qt 5.2.0 for iOS in the drop-down list that follows the search box (it's on the far right side and very easy to miss)

    • go to Projects and select iphoneos or iphonesimulator

    The build works and you can run the app in the simulator and on the device. It worked for me.



  • I got the similar problem.
    It sometimes came out Error 65 but sometimes went error-free. Could anyone tell me what's up with the mystery? Is there any information about Error 65?



  • I also get the mysterious "Error 65", trying to compile in Xcode I get a linker error: "Apple Mach-O Linker Error": Undefined symbols for architecture i386:
    "std::ios_base::Init::Init()", referenced from:
    ___cxx_global_var_init in libQt5Qml_iphonesimulator_debug.a(qqmlbundle.o)
    ___cxx_global_var_init in libQt5Qml_iphonesimulator_debug.a(qv4regexpobject.o)
    ___cxx_global_var_init in libQt5Qml_iphonesimulator_debug.a(qv4object.o)
    ___cxx_global_var_init in libQt5Qml_iphonesimulator_debug.a(qv4globalobject.o)
    ___cxx_global_var_init in libQt5Qml_iphonesimulator_debug.a(qv4functionobject.o)
    ___cxx_global_var_init in libQt5Qml_iphonesimulator_debug.a(qv4mm.o)
    ___cxx_global_var_init in libQt5Qml_iphonesimulator_debug.a(qv4debugging.o)
    ..

    and some other linker error, did anyone figure that oout yet? it works for with a hello world QML project and my project works on Mac OS, but not iOS, weird.



  • And I have the same problem. Most of all examples are built and run successfully for simulator, but when I am trying to build them for device it falls with same:

    === BUILD TARGET validators OF PROJECT validators WITH CONFIGURATION Release ===
    Check dependencies
    Code Sign error: No matching provisioning profiles found: No provisioning profiles with a valid signing identity (i.e. certificate and private key pair) were found.
    CodeSign error: code signing is required for product type 'Application' in SDK 'iOS 7.0'
    make[1]: *** [iphoneos-release] Error 65
    make: *** [release-iphoneos] Error 2
    17:40:19: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project validators (kit: iphoneos-clang Qt 5.2.1 for iOS)
    When executing step 'Make'

    Creating XCode project and attempt to build it ends with:
    make: addressbook.xcodeproj/qt_makeqmake.mak: No such file or directory
    make: *** No rule to make target `addressbook.xcodeproj/qt_makeqmake.mak'.



  • hey guys, found a simple solution today, at least for my debug error 65 problem above.

    the project was linked against the wrong c++ STD lib :o
    I don't know why Qt Creator is trying to link against the wrong lib, but here is the fix I used:

    • open the project with XCode
    • go to build settings
    • select "all" and search for the linker options
    • under "Other Linker Flags" change "-stdlib=libc++" to "-stdlib=libstdc++"

    yeah that is all, a rebuild should work now. :)

    note: I think the libstdc++ lib is the GNU version, don't knwo why the other isn't working maybe becaus ethe Qt libs are linked against libstdc++ and not libc++.



  • Bringing this back up.

    This fix worked in release 5.3 but no longer works in 5.4

    Is there a more current fix or work-around?



  • Bringing this back up.

    This fix worked in release 5.3 but no longer works in 5.4

    Is there a more current fix or work-around?



  • Problem still here...Qt 5.9 RC!!!!

    No signing certificate "iOS Development" found: No "iOS Development" signing certificate matching team ID "xxxxxxxxxx" with a private key was found.
    Code signing is required for product type 'Application' in SDK 'iOS 10.2'


  • Qt Champions 2016

    @AlterX
    up to Qt 5.8 something like this will work inside .pro:

    ios {
    .....
    QMAKE_XCODE_CODE_SIGN_IDENTITY = "iPhone Developer"
    MY_DEVELOPMENT_TEAM.name = DEVELOPMENT_TEAM
    MY_DEVELOPMENT_TEAM.value = CDXXXXXX2B
    QMAKE_MAC_XCODE_SETTINGS += MY_DEVELOPMENT_TEAM
    .....
    }
    

    see see https://bugreports.qt.io/browse/QTCREATORBUG-16968
    (take a look at all comments)

    the good news: Qt 5.9 and QtCreator 4.3 will make your life easier:
    http://blog.qt.io/blog/2017/05/24/qt-creator-4-3-0-released/


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.