Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Installing gsm-omx on Raspberry Pi



  • Hi,

    In relation to http://qt-project.org/forums/viewthread/32250/#152960, can anyone guide me on how to install gst-omx on Raspberry Pi?
    I have a project where I need to play some audio files (and preferrable also video), but all I get is the following message
    @defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer"@

    If I understand correctly, the core problem is that gst-omx is not correctly installed on my Raspberry Pi. I have tried to google around to find out how to properly install gst-omx but I haven't been successful in doing so.
    Can anyone help me out here???



  • The thread that you mentioned contains a link to "Beginner's guide to cross-compile Qt5 on RaspberryPi with QtMultimedia and libcec support":http://creeder.com/?page=RaspberryPi which includes instructions for gst-omx. Have you tried it out?



  • Yes I followed those guidelines for gst-omx, but that didn't help me out.



  • trying the same...
    Did you finally find out how to install gst-omx so that it can be used by qtmultimedia?



  • No unfortunately not... Most admit I have given up. If you find a solution, I am very keen to hear about this, though


Log in to reply