Error while building/deploying project on ios



  • Hi,

    currently I am trying out the new capabilities of Qt-Creator 3-rc1 with Qt5.2 for ios and I am not able to deploy my application to my iPhone (deployment in the simulator works). My iPhone is in Developer-Mode and deployment from within XCode is working. According to Preferences / Devices my iPhone is 'Ready to use'.

    Error message from Qt-Creator:

    ** BUILD SUCCEEDED **

    19:52:40: The process "/usr/bin/make" exited normally.
    19:52:40: TransferAppSession(67b7e62113cf9151d3a2d217e027bac2af119557, /Users/***/build-untitled5-iphoneos_clang_Qt_5_2_0_ios-Debug/Debug-iphoneos/untitled5.app)startService on device 67b7e62113cf9151d3a2d217e027bac2af119557 failed, AMDeviceStartService returned -402653057

    Error while building/deploying project untitled5 (kit: iphoneos-clang Qt 5.2.0 (ios))
    When executing step 'Deployment auf iPhone von ***'
    19:52:40: Elapsed time: 00:19.

    Any help is appreciated. :-D



  • I am also getting the same issue on two different Macs.

    If I open the project in Xcode it deploys fine. But when running from QTCreator it fails with the following errors.

    :-1: error: Deployment failed. The settings in the Organizer window of Xcode might be incorrect.

    ** BUILD SUCCEEDED **

    09:47:22: The process "/usr/bin/make" exited normally.
    09:47:23: TransferAppSession(2478af37f828e8f5722ab0ed9f9984ad79eb689a, /Users/john/build-test2-iphoneos_clang_Qt_5_2_0_for_iOS-Debug/Debug-iphoneos/test2.app)startService on device 2478af37f828e8f5722ab0ed9f9984ad79eb689a failed, AMDeviceStartService returned -402653057

    Error while building/deploying project test2 (kit: iphoneos-clang Qt 5.2.0 for iOS)
    When executing step 'Deploy to jiPhone'
    09:47:23: Elapsed time: 00:06.

    System Details

    Qt Creator 3.0.0
    Based on Qt 5.2.0 (Clang 4.2 (Apple), 64 bit)
    Built on Dec 10 2013 at 12:18:28
    From revision 27d10d8dcd

    iTunes 11.1.3 (8)

    Xcode Version 5.0.2 (5A3005)



  • We managed to get it working by ensuring Xcode and iTunes was closed, then disconnecting and reconnecting the iPhone a number of times.



  • I have the same problem.
    Here how I solved:

    • Go to Xcode, connect my device to Xcode automatic create provisioning profiles.
    • Go to QtCreator and set up Qt iOS Device kit, select the iPad I connected.


  • i find the error,may be it's some path error;

    TransferAppSession(/Users/kang/Qt5.2.0/5.2.0/ios/examples/build-gestures-iphoneos_clang_Qt_5_2_0_for_iOS-Debug/Debug-iphoneos/imagegestures.app,942d0a73d711f802f241acf1783823479d33b690) failed, AMDeviceTransferApplication returned -402653183

    The path /Users/kang/Qt5.2.0/5.2.0/ios/examples/build-gestures-iphoneos_clang_Qt_5_2_0_for_iOS-Debug/Debug-iphoneos/imagegestures.app not exist.

    The real path is :

    /Users/kang/Qt5.2.0/5.2.0/ios/examples/build-gestures-iphoneos_clang_Qt_5_2_0_for_iOS-Debug/imagegestures/Debug-iphoneos/imagegestures.app



  • I became aware of this through https://bugreports.qt-project.org/browse/QTCREATORBUG-11813 , please submit bugs when you find issues to ensure that they don't get lost.

    There seem to be two issues here:

    1. unreliable deploying which should have been solved in final/3.0.1

    2. issues with subdir projects, fixed in the 3.1 branch https://codereview.qt-project.org/#change,80503



  • I got the same error message, also in a setup where Xcode was working correctly. I believe the problem was that there were two versions of my Developer Certificate in my keychain, one of which was expired. Xcode uses the only valid one. After deleting the expired cert and re-running qmake I can now deploy from Creator. I'm using 3.1.1 / Qt 5.3, which are supposed to have fixed the referenced bug. Note that it could have been something else I did that fixed the problem... ymmv!


  • Lifetime Qt Champion

    @ rosetter

    Can you update the bug report with your information, it might give the iOS plugin developers some clue to improve it.



  • That bug was closed, so I created a new one.

    But I was about to post that my problem was not, in fact, solved.

    I'm not sure yet what conditions trigger it, but the error comes back. The solution that works now is unplug iPhone, plug back in. Go figure.



  • This post is deleted!

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.