Configure -top-level in qt5 configure.bat (unknown option)



  • Hi there,

    today I tried to make a rebuild of the latest qt5 repository.
    I did a git pull of the stable branch and then tried to run
    configure (under Windows XP).

    It turned out, however, that there was always the option "-top-level" added to my other configure options, which resulted in configure not completing: "Unkown option -top-level"

    Looking into the file qt5/configure.bat I found this line:
    @call %configure% -top-level %*@

    Changing it into
    @call %configure% %*@

    made it possible to complete configure.

    But afterwards I have no makefile in my qt5 directory...

    What am I missing??

    Thanks,
    Ludwick


  • Lifetime Qt Champion

    Hi,

    Did you just call git pull or did you follow this "guide":http://qt-project.org/wiki/Building_Qt_5_from_Git ?



  • Thanks for the quick reply! :-)

    I followed this guide about half a year ago, when I built qt for the first time. Then it all worked fine. So I thought, I could now just "git pull" and run "configure ..." "make" again to have the newest version.



  • I just checked out a completely fresh clone of the qt repository (following the quide) and now configure does not complain about the -top-level option:

    New checkout:

    D:\qt5-new>configure -help

    • cd qtbase
    • D:\qt5-new\qtbase\configure.bat -top-level -help
      Please wait while bootstrapping configure ...
      <srcbase> = D:/qt5-new/qtbase
      <outbase> = D:/qt5-new/qtbase
      mingw32-make: '../../configure.exe' is up to date.
      Usage: configure [options]

    However, my original checkout:

    D:\qt5>configure -help

    • cd qtbase
    • D:\qt5\qtbase\configure.bat -top-level -help
      Please wait while bootstrapping configure ...
      <srcbase> = D:/qt5/qtbase
      <outbase> = D:/qt5/qtbase
      mingw32-make: '../../configure.exe' is up to date.
      Unknown option -top-level
      Usage: configure [options]

    The files in the root directories of D:/qt5/ and D:/qt5-new/ are identical. What could be the cause for -top-level not being accepted by the former?


  • Lifetime Qt Champion

    Did you pull only qt5 ? Or did you also do it in the modules ?



  • I did just "git pull" in the qt5 root-directory; assuming it would update all subdirecotires recursively.

    I have to admit that I'm not very familiar with the concept of submodules in git. As a matter of fact, "git status" still shows me that the submodules are modfied and "git reset" does not change this.

    How should I have done the pull on all submodules, too?


  • Lifetime Qt Champion

    You can use qt5_tools from the qtrepotools


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.