No Debugger Set Up



  • Hi!!
    I have just started using qt.
    I was trying to run a open gl application in qt compiler. But the problem is that it shows No debugger setup .I want to debug the code. I have seen other posts in which people have said to configure CDB using :

    C:\Program Files (x86)\Windows Kits\8.0\Debuggers\x86\cdb.exe
    I am using Windows 8 but there is no cdb.exe in this folder . What should I do ?
    Any urgent help would be appreciated !!

    Regards,


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    AFAIK you need to download and install it from the Microsoft site. Have a look "here":http://msdn.microsoft.com/en-us/library/windows/hardware/ff551063(v=vs.85).aspx


  • Moderators

    Hi and welcome to DevNet.

    First of all there's no qt compiler. There's Qt - the library itself and an IDE called QtCreator. The compiler it uses can be either MSVC or MinGW (on Windows). In your case it's the former.
    To get CDB you need to install Debugging Tools for Windows, which are now part of Windows SDK. Online installer for it is "here":http://msdn.microsoft.com/en-us/windows/hardware/bg162891.aspx
    When you get to the components screen the only thing needed are the debugging tools. Other stuff is not necessary if you don't plan on using any Windows SDK features.
    After installing this head to the Kits setup in QtCreator Settings and hit autodetect in the selected kit debugger section.



  • Thanks a lot. It worked



  • Hi,

    I ama trying to install QT on debian. I get the same error when I try to debug sample example. Should I use GDB? How can I install it to debian? How should I configure it on QT? Thanks in advance

    Best Regards


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Please open your own thread since the OS concerned are not the same.

    In between you need to install some devel tools.

    @apt-get install gdb gdb-doc build-essential@



  • Hi, I am getting a similar problem although even after installing the Debugging Tools for Windows.

    I am running Windows 7 32-bit and have Qt Creator 3.0.1 and Debugging Tools for Windows from WDK 8.1 installed. I have set up CDB in Qt Creator’s Options window and it seems to recognize it as it detects an ABI (x86-windows-msvc2012-pe-32bit). I am using Visual C++ 2008, might this cause the issue?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    AFAIK, mixing VS2008 and WDK 8.1 is not possible. If you can, update your Visual Studio to the latest version (the express edition is free)


  • Moderators

    You might also try to install CDB from another package. I vaguely remember that my previous job setup worked with VS2008 and CDB from Windows SDK 8.0.

    Btw. I have VS2013 and Windows SDK 8.0 installed now and QtCreator shows this ABI for CDB: x86-windows-msvc2010-pe-32bit



  • Thanks for your advice, guys. Finally I got my above mentioned setup working. The only thing I had been missing was to choose the installed CDB in the Kits tab of Options window in Qt Creator (I only had it in Debuggers tab as I wrote the original post).

    I hadn’t paid attention to the Kits settings until I installed VS2013 and got more options there. :-) It remains working after uninstalling VS2013, so it seems to have no relation to it.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.