Unable to deploy to embedded (virtualbox) Linux



  • Hello there,
    I've installed (3 times so far) the Qt Enterprise with embedded Linux and Raspberry Pi but no matter what I do, when I try to deploy,build, or run anything, even the basic hello world, I see the virtual box running and hanging after without any reason.

    The configuration is correct, the IP address is correct, Qt Creator keeps telling me that VM put itself in a 'not ready' state and waiting for 30 seconds ... then that's it, nothing happens.

    I can provide screen shots (not sure how to show the situation)

    I am in Ubuntu 13.10 version 64bit with I believe all possible 32bit libraries installed.
    I've followed all tutorials without problems and got the example up and running in my RPi

    By any chance somebody can tell me what could possibly be the cause for this?
    I haven't tried yet to deploy directly to the PI but that would be unfortunate ... and as it is I am basically unable to evaluate the product.

    Thanks in advance for any further help.

    Best Regards



  • OK, I am testing via network directly on the RPi and at least it works as expected.

    I am not sure I should open a new thread but I am wondering if it's possible to enable webGL in the QtWebKit 3.0 instance I am using… pretty basic page that goes to http://get.webgl.org/ and fails showing the cube.

    Thanks



  • You may need to go through experimental APIs. WK2 APIs are very limited in Qt World.
    Ref : http://rschroll.github.io/beru/2013/08/21/qtwebview.experimental.html



  • that's a very interesting link, thanks … however, even setting experimental.preferences.webGLEnabled: true in my WebView I have no errors, I can deploy, still no webGL enabled.

    This is quite unexpected to me, I thought GL ES 2.0 was enabled in all layers, cannot see why Wayland would work for everything, including WebKit, but not WebGL … canvas, otherwise, seems to be fine (few black square here and there but … hey, nobody is perfect :D)

    Any other idea? Cheers


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.