Qt 5.1.1 & Android Deployment error.



  • Hi All,

    I have seen this issue discussed a little but haven't come across any solutions yet. Using Windows 7 and Qt 5.1.1.

    I am trying to deploy a simple app (MainWindow & a QButton) to an Android device (emulator or physical) and keep getting the error

    [code]
    10:55:52: Starting: "C:\Qt\Qt5.1.1_android\Tools\mingw48_32\bin\mingw32-make.exe" INSTALL_ROOT="C:\\Users\\User\\MyFirstAndroidApp\\android" install
    makefile:1607: recipe for target 'install_target' failed
    The system cannot find the path specified.
    The system cannot find the path specified.
    mingw32-make: *** [install_target] Error 1
    10:55:53: The process "C:\Qt\Qt5.1.1_android\Tools\mingw48_32\bin\mingw32-make.exe" exited with code 2.
    Error while building/deploying project MyFirstAndroidApp (kit: Android for arm (GCC 4.8, Qt 5.1.1))
    When executing step 'Copy application data'
    10:55:53: Elapsed time: 00:05.
    [/code]

    My paths all seem right;
    JDK is installed. Qt sees the NDK & SDK. 'adb devices' returns both the physical & emulated device and running 'ant' from a console window responds as expected.

    I am not sure what I could have missed, does anyone have any suggestions?

    Thanks.



  • Hi!
    Does your .apk file get created? Check your "C:\\Users\\User\\MyFirstAndroidApp\\android", is it there?
    Also I'm not sure, but why is there so many backslashes like "\\"?



  • Hi,

    I think the extra slashes happened when the forum or code block posted. The output doesn't have this and looks correct.

    No apk gets created anywhere I can see.



  • Is the build step succesfull?
    You may try to move your project to simplifed location like "C:\QtProjects\YourProject", sometimes it helps



  • Finally, I have an error!

    What you suggested seems to have worked, although I think indirectly.

    After I removed the .user file to set up the project again it started giving me errors about the JRE / JDK.

    I'll work though these and see how I go.

    Thanks.



  • This is the error I am now getting if anyone has any suggetions.

    http://pastebin.com/a3VvHVxd



  • I changed the target SDK and everything worked.



  • Im glad you did it :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.