[solved] Remote Deployment Option not visible in Run Settings despite successful setup in Qt Creator 2.8.1



  • I have with me the AM335X-Development kit(running the arago distribution) and I'm trying to setup remote deployment. But it seems like Qt Creator refuses to list the Device option under Deployment Method in Run Settings. This is after successfully connecting to the Device itself under Tools > Options > Devices > Add > Generic Linux Device. I was able Deploy a Public Key for ssh and use the Test/Show Running Process buttons to verify that I was indeed connected. However, in my project settings (Projects > Run Settings) I'm unable to see any options (other than Deploy locally) in the drop-down menu.

    My Qt Version is 2.8.1 and I'm running the 64 bit version of Ubuntu 12.04 on my host machine.



  • Was able to figure it out. Seems like the setup procedure is not the same as it was in previous versions of Qt Creator. I had to specify the usage of an embedded linux device in the Build options. This seems to restrict a specific Qt Kit to a particular target device.

    Had to RTFM "Setup Remote Target":http://qt-project.org/doc/qtcreator-2.6/creator-developing-generic-linux.html


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Thanks for sharing the solution. The current Qt sdks are indeed different from the one provided by Nokia in several aspects.

    Since you got it working, please update the thread title prepending [solved] so other forum user may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.