How to get MySQL plugin to run ?

  • Hey I started with Qt5 yesterday and since than I have problem like never before.

    I installed Qt 5.1.1 and tried the sql browser example because i need database support for
    an upcoming project.

    The problem is that I get the Error that says :
    @QSqlDatabase: QMYSQL driver not loaded
    QSqlDatabase: available drivers: QSQLITE QMYSQL QMYSQL3 QPSQL QPSQL7@

    That wasnt really helpful so far.
    As far as i understand the problem is that the plugin exist but it ran into an error.
    So I tried to check the dependencies:
    @ldd => not found
    And this is what I got. Ok this is the problem I guess. Because I didn't had the mysql devel packages installed
    when I installed Qt.

    All I have is the :
    @ /usr/lib/i386-linux-gnu/
    Is there a way to get this to work ?

    I tried to rebuild the plugin but ran into this kind of stuff:
    @qmake "INCLUDEPATH+=/usr/local/include" "LIBS+=-L/usr/local/lib -lmysqlclient_r"
    Project ERROR: addExclusiveBuilds() requires at least two arguments@

    Thanks for any reply.
    I'm pretty much stuck at this point.

  • I can't find a package which provides the
    Currently I have installed the libmysqlclient18 package and there is no such thing as a libmysqlclient16 available.

    So I tried to create a link to my current
    @/usr/lib/i386-linux-gnu/ -> /usr/lib/i386-linux-gnu/

    This seems to work in the first place but there has to be a better cleaner way to accomplish this. Any Ideas ?

    The sql browser example seem to work but in a stable environment I don't wanna run it this way.

  • Lifetime Qt Champion


    You can try to find an older version of the package which provide that or if you really want to be sure, you can rebuild the mysql plugin using your version of libmysqlclient

  • It would be a great help if the packages used to build the Plugins were
    listet in the documentation. I installed everything mentioned in the doc
    but still ran into this situation.

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.