Qt Application + Mac Os 10.9 Maverick



  • Hi guys,

    I have a question similar to "this one":http://qt-project.org/forums/viewthread/32495/, but it is a bit different. The problem is that I have an application written based on Qt 5.0.2, and it was perfectly compiling with Qt Creator 2.7.0 on Mac Os Mountain Lion. But a couple of days ago (who knows why) I have updated my Lion OS to the new OS Maverick, and it crashed my application completely. I could not even open Qt creator 2.7.0. I reinstalled Qt Framework to the Qt 5.2.0 with Qt Creator 2.8.8. The Qt Creator works, but when compiling my app I get a bunch of errors like

    error: variable has incomplete type 'class Q_WIDGETS_EXPORT'
    class Q_WIDGETS_EXPORT QSizePolicy
    ^

    If I change the path to Qt 5.0.2 still using Qt Creator 2.8.8, then I can compile without errors but, once my application is opened, it crashes with error similar to that one with Qt Creator 2.7.0 - "App quit unexpectedly."

    Please, if you know how to fix this stupid problem, let me know. I urgently need my application to work.

    P. S. I do not have any dependencies on the libraries based on Qt 4.
    P. P. S. The same errors appear if I compile with Qt Creator 2.8.1 and Qt 5.1.1.

    Thanks a lot in advance!



  • I have a similar problem..
    My qt app runs ONCE after I unpack it on my brand new OSX 10.9 Mavericks, then launching it a second time, it crashes.

    I found out.. when I go into super user mode, "sudo" it runs fine.

    Is there a way to allow all users to run the app by default, any settings, when I package the app? Or is this a Mavericks-sided problem?


  • Lifetime Qt Champion

    Hi,

    What version of Qt are you using ? What does the report say ?

    For Mavericks, you should use Qt 5.2, Apple did a lot of little changes that brought some problems



  • Hi, thanks..

    I've built and deploy-enabled my app on a different system (OSX 10.6.8) using Qt 5.1.1 with clang compiler and macdeployqt from that same Qt installation.

    So you're saying, I should rebuild the app with Qt 5.2 beta version - which could solve the problems?

    This one I assume..
    http://download.qt-project.org/development_releases/qt/5.2/5.2.0-beta1/

    I'll try and report back.



  • I tried to build my app with both Qt 5.1 and Qt 5.2, and it did not help me - the same error. Your app compiles at least once, mine does not compile at all, and I have no idea how to fix it. If you guys have any idea how to get rid of this, please let me know:

    error: variable has incomplete type ‘class Q_WIDGETS_EXPORT’
    class Q_WIDGETS_EXPORT QSizePolicy ^

    This is an internal error from Qt headers, not my headers.


  • Lifetime Qt Champion

    Rather the latest 5.2RC

    Since it seems widget related, did you add

    @QT += widgets@

    to your pro file ?



  • Actually I did, and the error did not disappear. But I have not tried 5.2RC - I will try it tomorrow and let you know. Thanks for help.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.