Important: Please read the Qt Code of Conduct -

Problem with the framebuffer on an ARM device

  • Hi all,
    I installed Qt Embedded on a ARM device with linux.
    There is a problem with the framebuffer.
    Running a simple application (./application -qws) it returns:
    @Cannot create semaphore /tmp/qtembedded-0/QtEmbedded-0 'd'
    Error 38 Function not implemented
    Cannot get display lock

    but when I try to run the framebuffer example application it returns

    @The framebuffer device was opened successfully.

    Fixed screen info:
    id: imapfb
    smem_start: 0x44800000
    smem_len: 4718592
    type: 0
    type_aux: 0
    visual: 2
    xpanstep: 0
    ypanstep: 1
    ywrapstep: 0
    line_length: 2048
    mmio_start: 0x20cd0000
    mmio_len: 16384
    accel: 0
    The framebuffer device was mapped to memory successfully.
    Successfully switched to graphics mode.
    Variable screen info:
    xres: 1024
    yres: 576
    xres_virtual: 1024
    yres_virtual: 1152
    yoffset: 0
    xoffset: 0
    bits_per_pixel: 16
    grayscale: 0
    red: offset: 11, length: 5, msb_right: 0
    green: offset: 5, length: 6, msb_right: 0
    blue: offset: 0, length: 5, msb_right: 0
    transp: offset: 0, length: 0, msb_right: 0
    nonstd: 0
    activate: 0
    height: 0
    width: 0
    accel_flags: 0x0
    pixclock: 46213560
    left_margin: 128
    right_margin: 15
    upper_margin: 21
    lower_margin: 5
    hsync_len: 104
    vsync_len: 4
    sync: 0
    vmode: 0
    Frame Buffer Performance test...
    Average: 39244 usecs
    Bandwidth: 114.667 MByte/Sec
    Max. FPS: 25.482 fps
    Will draw 3 rectangles on the screen,
    they should be colored red, green and blue (in that order).

    How can I solve?
    I changed the permission to the file /tmp/qtembedded-0/QtEmbedded-0 but it returns a "wrong permissions" error

    Thank you in advance for your help. I spent the last 3 days around this problem


  • When you launch the framebuffer example, did you have the three rectangle on the screen?
    Have you write permission on your partition including the /tmp directory? Perhaps this partition is read-only? What the result of "mount" command?

  • Thank you very much ngrosjean for you replay.
    I'm very disperate!

    When I launch the framebuffer example there are the three rectangles on the screen in the right order and the output is written in my previous post.
    I tried to change the permissions on /tmp directory. /tmp is a link to /var/tmp so I changed the permission on /tmp/var.
    When I try to run another example after changed the permission the system returns a "wrong permissions" error.
    This evening I'll try the mount command and I'll post a replay.

    Thank you again


  • I have recently had the same problem. Turned out that I had to include System V IPC option in the kernel.

Log in to reply