[solved] Build error on Linux



  • Hi,
    I am trying to test Qt in a branch of Ubuntu 12.04 based Linux distribution.
    I created a blank desktop application and I get this lib error compiling:

    /home/francisco/Qt5.1.1/5.1.1/gcc/bin/uic ../prueba/mainwindow.ui -o ui_mainwindow.h
    g++ -c -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I../Qt5.1.1/5.1.1/gcc/mkspecs/linux-g++ -I../prueba -I../Qt5.1.1/5.1.1/gcc/include -I../Qt5.1.1/5.1.1/gcc/include/QtWidgets -I../Qt5.1.1/5.1.1/gcc/include/QtGui -I../Qt5.1.1/5.1.1/gcc/include/QtCore -I. -I. -I. -o mainwindow.o ../prueba/mainwindow.cpp
    g++ -Wl,-O1 -Wl,-rpath,/home/francisco/Qt5.1.1/5.1.1/gcc -Wl,-rpath,/home/francisco/Qt5.1.1/5.1.1/gcc/lib -o prueba main.o mainwindow.o moc_mainwindow.o -L/home/francisco/Qt5.1.1/5.1.1/gcc/lib -lQt5Widgets -lQt5Gui -lQt5Core -lGL -lpthread
    /usr/bin/ld: cannot find -lGL
    collect2: ld returned 1 exit status

    Can anybody help me with the GL library or telll me what is wrong?
    Thanks
    PS: I installed many OpenGL libraries but without success


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you install the libgl1-mesa-dev package ?



  • Thanks a lot, it was the problem, now it works.


  • Lifetime Qt Champion

    You're welcome !

    Please update the thread title by prepending [solved] so other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.