Qt World Summit: Submit your Presentation

[SOLVED]The application was unable to start correctly (0xc000007b).

  • Hello, I released my app but I can not run it. Everything works fine while debugging, even while press release, but when I want to run my application out of Qt Creator, I get following error.

    bq. The application was unable to start correctly (0xc000007b).
    Click OK to close the application. bq.

    What is problem??? I included all necessary .dll files in same folder like app, but still get this error...
    This is what dependency walker show... I guess problem is in QMultimedia.dll cus it's x86, but how can I use it if it only supports x86 CPU??? Any how can I build my application for x86 and x64 system... I am using Qt_5_1_1_MSVC2012_OpenGL_64bit... It builds everything x64 based, how can I change it into x86???

    Link to image -> http://img12.imageshack.us/img12/6739/1fac.png


  • Lifetime Qt Champion


    If you want to do x86, you need a x86 build of Qt also. What puzzles me is that you have the Qt5Multimedia dll has x86, how is that possible ?

  • I don't know how is that possible... I installed x86 Qt build and now I am getting another error... It works fine in Qt, but when I release it prints me error above... I am using Windows 8 64 bit

    @This application failed to start because it could not find or load the Qt platform plugin "windows".

    Available platform plugins are minimal, offscreen, windows.

    Reinstalling the application my fix the problem.@

  • Fixed with adding libEGL.dll into the same folder as .exe -> for x86 qt build

    By the way, before I uninstalled x64 Qt application somehow started working... Same app, same folder, just I took all .dlls and placed them in folder with .exe ... I guess this Qt version has some bugs and is not working if some of dlls are not included, but program itself won't tell which one is missing...


  • I had the same problem. I used "Dependency Walker" and after a while it reported back those .dll files my app was loading. I noticed that the app was using x86 version of "libstdc++-6.dll". I went to Qt's installation folder to "mingw73_64" sub folder and "bin" and copy/replaced the .dll file from there and app run. I dont know why Qt's "windeployqt.exe" used x86 version.

  • @MhmRhm How do i get the correct version of these file, seems like i am facing the same problem

Log in to reply