[Solved - sort of] invalid installation package



  • Hi

    I have made an app for the N9 in Qt creator (Qt 4.8), it works great when i run it on the device from the creator, but whenever I try to install the package I get an error saying "Can't install. Invalid installation package".

    Can anyone tell me what's wrong with the package, or how I can find out what's wrong with it ?

    The package can be downloaded here : https://openrepos.net/content/kif/osmapper.

    I have other projects where the installation package works fine, so it should not be the Qt environment that's at fault.

    Kim



  • No one ?

    Kim



  • The problem has been solved, but unfortunately not in an informative way :(

    The problem persisted on my phone, even after a total recreation of the control file.

    I could install the package from cli as developer, but was unable to install using the gui.

    After un-installing from cli, I was able to install using the gui.

    I do believe the problem was something in the control file (as I was made aware of the problem, by a users trying to install the app, who had not installed the app as developer), even though I (still) cannot see what the problem should be.

    Kim


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.