[Solved] Qt 5.1.1 on Win7 64bit shows error on startup, but seems to work afterwards



  • Hi forum,

    I just installed the latest version of Qt (5.1.1) via the online installer for Windows on a Win7 64bit PC.

    The installation worked quite smoothly, but upon starting Qt Creator, a message pops, which says "The application could not be started correctly (0xc000007b). Click "OK" in order to close the application". The header of the message window says "cc1plus.exe - application error".

    When I click "OK", the message re-appears two times and then Qt Creator opens and seems to work OK. I could compile an own project and the example "Qt Quick Controls - Gallery" successfully. However, I'm a bit nervous because of the error message.

    Can anyone tell me what this cc1plus.exe is used for and which restrictions I might face due to the error? How can the error message be overcome? Is an update to my MinGW installation necessary? If yes, which modules?

    Any help is appreciated. My google search led to no clues so far.

    Take care,
    Steffen

    P.S.: While writing this, I had the error message open all the time and I just noticed that after ignoring it 1-2 minutes, Qt Creator started all the same and again seems to work OK. The error message stayed on the screen and I had to click "OK" three times as before in order to get rid of it.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    I guess you installed the 5.1.1 MinGW 32Bit, do you have your own MinGW installed on your machine ?



  • Hi SGaist,

    thanks for your reply. Yes, I installed 5.1.1 MinGW 32bit and I already had my own MinGW installed before installing Qt. Actually, I just figured out, what was the problem:

    Dependency Walker showed a missing dll called zlib1.dll, which cc1plus.exe needs. Now I put this file in the same folder as cc1plus.exe and Qt creator starts without error message.

    By the way, Dependency Walker also showed some problems for Qtcreator.exe, but they don't seem to be too severe or are no problems in reality - al least I didn't experience any trouble so far.

    If anyone else reads this and is about to use Dependency Walker for the first time: By sure to use the version, which matches the application: 32bit Dependency Walker for 32bit application and 64bit Dependency Walker for 64bit application. Using 64bit Dependency Walker on a 32bit application produces a whole list of problems, which don't exist in reality.

    Best regards,
    Steffen


  • Lifetime Qt Champion

    Glad you found out !

    Having multiple version of MinGW installed seems to pose problem (you're not alone)

    If you got it working, please update the thread title prepending [solved] so other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.