Not enough disk space to store temporary files!



  • Hello, everyone!
    My OS is
    Linux version 3.6.10-4.fc18.x86_64 (mockbuild@) (gcc version 4.7.2 20121109 (Red Hat 4.7.2-8) (GCC) ) #1 SMP Tue Dec 11 18:01:27 UTC 2012

    I downloaded qt-linux-opensource-5.1.1-x86_64-offline.run from qt-project.org.
    when I instaled it, shell told me that
    Not enough disk space to store temporary files! Available space:370.20MiB, at least required: 649.56MiB

    I thought my disk had enough space, I took fisk -l, it showed
    Device Boot Start End Blocks Id System
    /dev/sda1 * 63 52468289 26234113+ 7 HPFS/NTFS/exFAT
    /dev/sda2 155653785 625121279 234733747+ f W95 Ext'd (LBA)
    /dev/sda3 52469760 53493759 512000 83 Linux
    /dev/sda4 53493760 155652095 51079168 8e Linux LVM
    /dev/sda5 155653848 311307569 77826861 7 HPFS/NTFS/exFAT
    /dev/sda6 311307633 466961354 77826861 7 HPFS/NTFS/exFAT
    /dev/sda7 466961418 625121279 79079931 7 HPFS/NTFS/exFAT

    Could you help me? Thank you very much!


  • Moderators

    Can you show df -h output ?
    Clearly from the output log it seems you dont have enough space.



  • Great! Thank p3c0 very much!
    when I put df -h, it showed me,
    Filesystem Size Used Avail Use% Mounted on
    rootfs 47G 6.7G 38G 16% /
    devtmpfs 354M 0 354M 0% /dev
    tmpfs 371M 140K 371M 1% /dev/shm
    tmpfs 371M 2.2M 369M 1% /run
    tmpfs 371M 0 371M 0% /sys/fs/cgroup
    /dev/mapper/fedora-root 47G 6.7G 38G 16% /
    tmpfs 371M 371M 0 100% /tmp
    /dev/sda3 485M 70M 390M 16% /boot

    There must be not enough space in /tmp!!!



  • Hi.
    I got similar error, but message is "Not enough disk space to store temporary files! Available space: 0.00 bytes, at least required: 495.25 MiB". I am using Linux too. I tried running online, offline, 64- and 32bit versions, all gets same error.

    There is a df -h output:
    Filesystem Size Used Avail Use% Mounted on
    rootfs 25G 15G 8.8G 63% /
    802 25G 15G 8.8G 63% /
    tmpfs 390M 392K 389M 1% /run
    udev 10M 0 10M 0% /dev
    shm 2.0G 0 2.0G 0% /dev/shm
    cgroup_root 10M 0 10M 0% /sys/fs/cgroup
    /dev/sda4 411G 131G 259G 34% /home

    How to get installer work?



  • I got to this via a google search while trying to work out the issue. It's the only hit that fit my issue, and it's not super old, so I figure that I should log in and post an answer here. My problem was similar to sculida2's in that my /tmp partition was 512MB, short of the ~580MB required by the installer. In sculida2's case and in mine, /tmp is using tmpfs, which means that it's storing temp files in memory instead of on hard storage.

    In /etc/fstab, /tmp is defined like this:
    @tmpfs /tmp tmpfs size=512M@

    I changed it to
    @tmpfs /tmp tmpfs size=1024M@

    then I typed (as root)
    @mount -o remount /tmp@

    A quicker way to do it without modifying the /etc/fstab startup file would be to type
    @mount -o remount,size=1024M tmpfs /tmp/@

    After either way, you'll find that you have a completely empty /tmp with all the space available for the installer! Mind that the sudden emptiness of the /tmp directory may throw currently programs into a hissy fit, so it's good practice to log out and just use a Ctrl+Alt+F1 vtty. I did it with a full KDE, two instances of Firefox, and many other programs running, and there was no problem, though.

    Also note that since tmpfs stores files in memory, having the half gigabyte of qt installer temp files will make that much memory unavailable, so be careful if you do not have a lot of RAM in your computer.

    You might be able to do that single command if you, as in Abuyin's case, have /tmp on the hard drive. It will revert to the old way the next time you reboot.

    Remember that you need root access (precede the command with sudo if you're logged in as a regular user) to run the above commands and to edit the fstab file.



  • I've similar issue and I couldn't find a solution for it!

    May I get some help guys?

    mbnoimi@mbnoimi-laptop ~ $ df -h
    Filesystem              Size  Used Avail Use% Mounted on
    /dev/sda6                89G   84G  568M 100% /
    none                    4.0K     0  4.0K   0% /sys/fs/cgroup
    udev                    1.9G  4.0K  1.9G   1% /dev
    tmpfs                   387M  1.5M  385M   1% /run
    none                    5.0M     0  5.0M   0% /run/lock
    none                    1.9G   88K  1.9G   1% /run/shm
    none                    100M   36K  100M   1% /run/user
    /dev/sda3               362G  196G  148G  58% /home
    /home/mbnoimi/.Private  362G  196G  148G  58% /home/mbnoimi
    /dev/sdb1               3.6T  2.0T  1.5T  57% /media/mbnoimi/Media
    mbnoimi@mbnoimi-laptop ~ $ 
    
    

    I'm using:

    • Linux mint 17.2 x64 xfce
    • qt-unified-linux-x64-2.0.2-2-online.run


  • Using "bleachbit" I could fix this issue.

    Thanks


  • Moderators

    @mbnoimi Since you don't have an extra partition for /tmp it is part of your root partition /.
    Free space on your root partition is 568M:

    /dev/sda6                89G   84G  568M 100% /
    

    The solution is: make some more space in your root partition by deleting unneeded stuff (84G is quite much for a root partition!).


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.