Eglfs not loaded



  • i finally have been able to cross compile qt 5.1.1 to my linux armel platform including eg2.

    the libqeglfs.so is in /opt/qt5.1/plugins/platforms
    i have exported this path to QT_PLUGIN_PATH=/opt/qt5.1/plugins

    but when i run i get:
    @falcon@linaro:~$ ./shadereffects -platform eglfs
    This application failed to start because it could not find or load the Qt platform plugin "eglfs".

    Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

    Reinstalling the application may fix this problem.
    Aborted@

    any hints of where to look first ? i looked in /var/log/syslog but nothing there



  • When I got same problem, I've investigated which library dependency is missing for /usr/lib/qt5/plugins/platforms/usr/lib/qt5/plugins/platforms/libqeglfs.so and the libudev.so.0 was missing. So you may need to deploy udev as well.



  • thanks raytry,

    i stopped looking a while ago and am now using xcb instead.
    but i appreciate you taking the time and sharing this.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.