QTOpenCL configuring and installation



  • Hello! I wanted to start with QTOpenCL, so I did:

    @git clone git://gitorious.org/qt-labs/opencl.git@

    Previously, I had installed qtcreator and qtdesigner. So I tried:

    @$ ./configure

    This is the QtOpenCL configuration utility.

    ./configure: /usr/bin/qmake must be at least version 4.6.0
    Specify the correct qmake binary with the -qmake option
    @

    Checking qmake version and where it is:

    @$ whereis qmake
    qmake: /usr/bin/qmake /usr/bin/X11/qmake

    $ /usr/bin/qmake --version
    QMake version 3.0
    Using Qt version 5.0.1 in /usr/lib/x86_64-linux-gnu@

    I thought having QT version > 5.0 I could install QTOpenCL correctly, but it seems incorrect. So what can I do?



  • I had installed @qmake-qt4@ So I did:

    @./configure -qmake /usr/bin/qmake-qt4 -I <NVIDIA-OPENCL-PATH>@


  • Lifetime Qt Champion

    Hi,

    If i have read the information correctly, QtOpenCL was designed for Qt 4 I can't however tell you whether some work for Qt 5 has been done.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.