Important: Please read the Qt Code of Conduct -

How to change toolchain [MacOSX]

  • Hi!
    Recently I migrate to MacOSX 10.8.4 with QtCreator 2.8.0.
    I install XCode and command line tools from AppStore, but unfortunately it include only gcc 4.6 which isn't support futures from C++0x/11
    Then I install from macports gcc 4.8 and add it to QtCreator->Preferences->Build & Run->Compilers and specify this compiler in Kit settings.
    But as I understand I miss something, because after that qmake generate in Makefile:
    CC = /Applications/
    CXX = /Applications/
    but my compiler situated in /opt/local/bin
    how to fix it?

  • I find solution right after the puplic this post.

    QMAKE_CC = /opt/local/bin/x86_64-apple-darwin12-gcc-4.8.1
    QMAKE_CXX = /opt/local/bin/x86_64-apple-darwin12-g++-mp-4.8

  • Lifetime Qt Champion


    IIRC you should be using clang with that version of Xcode

Log in to reply