Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Opencv and qt 5.1 integration [SOLVED]



  • Hi,
    using opencv-2.4.6, Qt 5.1 on OpenSuse 12.2 64 bit, i run my software and i have:
    QMetaType::registerType: Binary compatibility break -- Size mismatch for type 'QPaintBufferCacheEntry' [1024]. Previously registered size 0, now registering size 16.

    I tryed also with some example downloaded from internet and i have same error.
    What's happen?


  • Lifetime Qt Champion

    Hi,

    You probably have OpenCV built with Qt 4 (check opencv_highgui with ldd) So you can't use it like this with Qt5, you should either rebuild OpenCV with Qt 5 (I don't know it its already possible) or rebuild it without Qt.

    Hope it helps



  • yes, i recompiled opencv and it's ok. Thanks


  • Lifetime Qt Champion

    You're welcome !

    Don't forget to update the thread's title to solved so other forum users will know a solution has been found :)



  • Hi.
    how did u recompiled it? I'm getting errors. particularly when i check WITH_QT in cmake.

    tnx

    [quote author="niqt" date="1377376785"]yes, i recompiled opencv and it's ok. Thanks[/quote]



  • I have also configured $PATH=/home/myhome/Qt5.1.1/5.1.1/gcc/bin:$PATH


Log in to reply