[SOLVED] Error: Failed to start program. Path or permissions wrong?



  • Getting the following error:

    Starting /opt/Qt5.0.2/5.0.2/gcc/bin/serialbutton...
    Failed to start program. Path or permissions wrong?
    /opt/Qt5.0.2/5.0.2/gcc/bin/serialbutton exited with code -1

    The compiler output shows:
    16:01:34: Running steps for project serialbutton...
    16:01:34: Configuration unchanged, skipping qmake step.
    16:01:34: Starting: "/usr/bin/make"
    make: Nothing to be done for `first'.
    16:01:34: The process "/usr/bin/make" exited normally.
    16:01:34: Elapsed time: 00:00.

    I've tried the solutions suggested in the earlier discussions.
    Still, haven't been able to get rid of this error.

    Please help.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Are you sure that your application should go in "/opt/Qt5.0.2/5.0.2/gcc/bin/" ?

    That doesn't look like a normal destination folder when building an application.



  • In the RUN configuration, the path of the Executable file is fixed to “/opt/Qt5.0.2/5.0.2/gcc/bin/” (I am not able to change it).


  • Lifetime Qt Champion

    What does it show in the build panel under Build Directory ?



  • It shows:
    Build Directory: /opt/Qt5.0.2/5.0.2/gcc/bin



  • I copied the project to a different path as you suggested and now it's working fine.
    However, why it couldn't compile in the previous path is mysterious.


  • Lifetime Qt Champion

    I would guess no write rights

    Anyway, you should not use such path for project building. Have your code somewhere in your home directory and use the shadow build option from QtCreator, this way you'll be safe.

    Sine it's all working now, please update the thread's title to solved so other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.