[Solved] Qt application error 127 on AMD machine but not Nvidia



  • Not sure if this is the correct forum for this but here goes.

    We're developing a Qt application for Windows using vc++2005. I originally built Qt 4.8.4 on my machine which has an Nvidia graphics card. Everything was fine until we tried running the application on a collegue's machine that's running and AMD graphics card. Now when I try to instantiate a QGLWidget I'm greeted with

    "LoadLibrary failed with error 127: The specified procedure could not be found."

    The output in VS says

    'Application.exe': Loaded 'C:\Windows\System32\atio6axx.dll', No symbols loaded. First-chance exception at 0x77c1d7d8 in Application.exe: 0xC0000139: Entry Point Not Found. 'Application.exe': Unloaded 'C:\Windows\System32\atio6axx.dll'

    I played around with older versions of the drivers and building the Qt libraries on each computer but still get the same error message. I also tried running on another computer with and AMD card, the program runs with generic video drivers but when you use the AMD ones I get this error.

    I've made an "SO post as well":http://stackoverflow.com/questions/18149100/qt-application-crashing-when-machine-has-amd-card-but-not-with-nvidia but haven't received any helpful responses yet.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You might want to bring this question to the interest mailing list, you'll find there Qt's developers/maintainers (this forum is more user oriented)



  • Thanks SGaist.

    We figured out the issue late last week.

    We had a dll from another build called Version.dll. This was in visual studio's path. It appears that one of the AMD dlls was trying to access another dll called Version.dll and Windows was sending our Version.dll before AMD's and this threw the error. Renaming our library fixed the issue.

    Thanks for the advice about mailing list, next time I have one of these knids of errors i'll look there.


  • Lifetime Qt Champion

    You're welcome !

    Great you found out and thanks for sharing !

    Don't forget to update the thread's title to solved so other forum users may know that a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.