Does QT for X11 include QT Creator?



  • HI, I am new to QT, and I installed QT 5.1.0 for X11 (qt-everywhere-opensource-src-5.0.2.tar.gz) on my rhel 6 machine. This includes Designer, Assistant, etc., and I assumed it also included Creator but I can't find it anywhere. Do I need to download QT Creator separately? If so, does the QT 5.1.0 that I just installed have all the necessary libraries for QT Creator? Thanks!


  • Moderators

    No, source packages for Qt contain Qt libraries only. Qt Creator is a separate product (but is shipped with prebuilt Qt SDKs). And yes, the libraries you have are enough for Creator. Just check out it's README for instructions.



  • And please, note that it is Qt, not QT. QT is usually associated with Apple's QuickTime, and we don't want that association do we?


  • Moderators

    [quote author="Andre" date="1375773035"]QT is usually associated with Apple's QuickTime, and we don't want that association do we?[/quote]

    Hell no :) But I grew tired of seeing that being pointed out everywhere, so I stopped paying attention when people get it "wrong". It is not a big mistake anyway. And Google searches in lowercase only, so for them Qt and QT are equal.



  • Sierdzio, thanks for the help. I downloaded Creator and opened the README file for installation instructions. But the qmake -r command wouldn't work. There isn't a Makefile at the top level. I found a Makefile.linux in one of the subdirectories. Should I use that?


  • Lifetime Qt Champion

    Hi,

    Did you download the sources or the pre-built version of QtCreator ?



  • I downloaded Qt Creator source code tar.gz (which is "qt-creator-2.8.0-src.tar.gz").



  • I'd say: why don't you try and see if QtCreator isn't already provided as a package by your distro, or perhaps even an alternate repository for your distribution?


  • Moderators

    It should work, then. This is what I usually do to build QtC:
    @
    cd /my/extracted/qtcreator
    mkdir build
    cd build
    qmake ../qtcreator.pro
    make -j9
    @

    That's it. So far it has worked every time, also when building with QBS enabled.



  • Thank you. I followed the instructions, and I received these errors after the qmake:

    qtcreator.pri:7: Unknown test function: isEqual
    qtcreator.pri:19: Unknown test function: defineReplace
    qtcreator.pri:32: Unknown test function: defineReplace
    qtcreator.pri:38: Unknown test function: defineReplace
    qtcreator.pri:51: Unknown test function: defineTest
    qtcreator.pri:74: Unknown test function: isEqual
    qtcreator.pri:85: Unknown test function: defineReplace
    qtcreator.pri:100: Unknown test function: CONFIG
    qtcreator.pri:118: Unknown replace function: re_escape
    qtcreator.pri:119: Unknown replace function: cleanPath
    qtcreator.pri:120: Unknown replace function: re_escape
    qtcreator.pri:149: Unknown test function: isEqual
    qtcreator.pri:156: Parse Error ('$$IDE_SOURCE_TREE/src/libs $$IDE_SOURCE_TREE/tools $$IDE_SOURCE_TREE/src/plugins')
    qtcreator.pro:4: Unknown test function: minQtVersion
    Project MESSAGE: Cannot build Qt Creator with Qt version .
    Project ERROR: Use at least Qt 4.8.0.


  • Lifetime Qt Champion

    What does your qmake --version return ?



  • Qmake version: 1.07a (Qt 3.3.8b)


  • Lifetime Qt Champion

    3.3.8 ? It's a really really old qmake... What system are you running that uses such an outdated Qt ?



  • rehl 6


  • Lifetime Qt Champion

    Like the error message says, you have to first install at least Qt 4.8



  • I downloaded the Qt source code tar.gz (which is “qt-everywhere-opensource-src-5.1.0.tar.gz”) and used the instructions from http://qt-project.org/doc/qt-5.0/qtdoc/install-x11.html to make and install. I also downloaded Qt Creator source code tar.gz (which is “qt-creator-2.8.0-src.tar.gz”), looked at the README file for installation instructions, but the qmake didn’t work. So, evidently the system isn't recognizing the newer version of Qt. How can I fix that?


  • Lifetime Qt Champion

    You can simply use the full path to your Qt 5.1 qmake.

    Building & installing Qt from sources won't overwrite your system Qt install (that would wreak havoc)



  • Okay, thanks! That worked. After the qmake worked, I continued to follow sierdzio's instructions (shown below), and performed the "make -j9".

    1. cd /my/extracted/qtcreator
    2. mkdir build
    3. cd build
    4. qmake ../qtcreator.pro
    5. make -j9

    After the "make -j9", it appeared to make until I received these errors:

    make[3]: Leaving directory /home/cpatterson/Downloads/qt-creator-2.8.0-src/build/src/libs/ssh' make[2]: Leaving directory/home/cpatterson/Downloads/qt-creator-2.8.0-src/build/src/libs'
    make[1]: *** [sub-libs-make_first-ordered] Error 2
    make[1]: Leaving directory `/home/cpatterson/Downloads/qt-creator-2.8.0-src/build/src'
    make: *** [sub-src-make_first-ordered] Error 2

    Do you know what's wrong with this? I'm sorry to know such a small amount, but I'm trying to learn. Thanks!


  • Lifetime Qt Champion

    You'll have to post more lines, where the error currently happens



  • Is this what you mean? These are the last lines in the make.

    ln -s libQtcSsh.so.1.0.0 libQtcSsh.so
    ln -s libQtcSsh.so.1.0.0 libQtcSsh.so.1
    ln -s libQtcSsh.so.1.0.0 libQtcSsh.so.1.0
    rm -f ../../../lib/qtcreator/libQtcSsh.so.1.0.0
    rm -f ../../../lib/qtcreator/libQtcSsh.so
    rm -f ../../../lib/qtcreator/libQtcSsh.so.1
    rm -f ../../../lib/qtcreator/libQtcSsh.so.1.0
    mv -f libQtcSsh.so.1.0.0 ../../../lib/qtcreator/
    mv -f libQtcSsh.so ../../../lib/qtcreator/
    mv -f libQtcSsh.so.1 ../../../lib/qtcreator/
    mv -f libQtcSsh.so.1.0 ../../../lib/qtcreator/
    make[3]: Leaving directory /home/cpatterson/Downloads/qt-creator-2.8.0-src/build/src/libs/ssh' make[2]: Leaving directory/home/cpatterson/Downloads/qt-creator-2.8.0-src/build/src/libs'
    make[1]: *** [sub-libs-make_first-ordered] Error 2
    make[1]: Leaving directory `/home/cpatterson/Downloads/qt-creator-2.8.0-src/build/src'
    make: *** [sub-src-make_first-ordered] Error 2


  • Lifetime Qt Champion

    Don't you have other lines that contains "error" ?



  • No. Unless there are some that have rolled off the command window (which retains 680 lines).


  • Lifetime Qt Champion

    You can redirect the output to a file and inspect it to see where the error happened



  • You are right. There are several errors. Here are some of them:

    g++ -c -pipe -Werror -O2 -fvisibility=hidden -fvisibility-inlines-hidden -Wall -W -D_REENTRANT -fPIC -DQT_CREATOR -DQML_BUILD_STATIC_LIB -DQBS_LIBRARY -DSRCDIR="/home/cpatterson/Downloads/qt-creator-2.8.0-src/src/shared/qbs/src/lib" -DQBS_VERSION="1.0.1" -DQT_NO_DEBUG -DQT_XML_LIB -DQT_CONCURRENT_LIB -DQT_TESTLIB_LIB -DQT_SCRIPT_LIB -DQT_CORE_LIB -DQT_TESTCASE_BUILDDIR="/home/cpatterson/Downloads/qt-creator-2.8.0-src/build/src/shared/qbs/src/lib" -I/usr/local/Qt-5.1.0/mkspecs/linux-g++ -I/home/cpatterson/Downloads/qt-creator-2.8.0-src/src/shared/qbs/src/lib -I/home/cpatterson/Downloads/qt-creator-2.8.0-src/src/shared/qbs/src/lib -I/home/cpatterson/Downloads/qt-creator-2.8.0-src/src/shared/qbs/src -I/usr/local/Qt-5.1.0/include -I/usr/local/Qt-5.1.0/include/QtXml -I/usr/local/Qt-5.1.0/include/QtConcurrent -I/usr/local/Qt-5.1.0/include/QtTest -I/usr/local/Qt-5.1.0/include/QtScript -I/usr/local/Qt-5.1.0/include/QtCore -I. -I. -o project.o /home/cpatterson/Downloads/qt-creator-2.8.0-src/src/shared/qbs/src/lib/api/project.cpp
    .
    .
    .
    cc1plus: warnings being treated as errors
    /usr/local/Qt-5.1.0/include/QtCore/qbytearray.h:433: error: dereferencing pointer ‘<anonymous>’ does break strict-aliasing rules
    /usr/local/Qt-5.1.0/include/QtCore/qbytearray.h:438: error: dereferencing pointer ‘<anonymous>’ does break strict-aliasing rules
    /usr/local/Qt-5.1.0/include/QtCore/qarraydata.h:104: error: dereferencing pointer ‘<anonymous>’ does break strict-aliasing rules
    /usr/local/Qt-5.1.0/include/QtCore/qgenericatomic.h:96: error: dereferencing pointer ‘<anonymous>’ does break strict-aliasing rules
    /usr/local/Qt-5.1.0/include/QtCore/qbytearray.h:395: note: initialized from here
    make[3]: *** [project.o] Error 1
    make[3]: *** Waiting for unfinished jobs....
    .
    .
    .
    /usr/local/Qt-5.1.0/include/QtCore/qstring.h:918: note: initialized from here
    make[3]: Leaving directory `/home/cpatterson/Downloads/qt-creator-2.8.0-src/build/src/shared/qbs/src/lib'
    make[2]: *** [sub----shared-qbs-src-lib-make_first] Error 2
    make[2]: *** Waiting for unfinished jobs....


  • Moderators

    You need to add it to PATH, or use directly:
    @

    either

    export PATH=/path/to/qmake:$PATH

    or

    /path/to/qmake/qmake myProject.pro
    @


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.