Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[SOLVED] Failed to load platform plugin xcb



  • I get the error message below when trying to start my application.

    @bq. $ ../DR_install/ext/bin32/drgui
    Failed to load platform plugin "xcb". Available platforms are:
    linuxfb
    minimal
    offscreen
    xcb

    Aborted@

    xcb is listed as an option and I believe I have all xcb dependencies installed, so I don't know why it's not being used.
    @$ rpm -qa | grep xcb
    libxcb-1.9-3.fc19.x86_64
    xcb-util-0.3.9-2.fc19.i686
    libxcb-devel-1.9-3.fc19.x86_64
    xcb-util-keysyms-0.3.9-2.fc19.i686
    xcb-util-keysyms-0.3.9-2.fc19.x86_64
    xcb-util-devel-0.3.9-2.fc19.x86_64
    xcb-util-devel-0.3.9-2.fc19.i686
    libxcb-devel-1.9-3.fc19.i686
    xcb-util-0.3.9-2.fc19.x86_64
    libxcb-1.9-3.fc19.i686@

    I have Qt5.1.0 32-bit on Fedora 19 64-bit. I used the offline installer to install Qt (not with sudo).
    It is my own application that I am trying to start, and there are no build errors.

    I followed "this post":https://qt-project.org/forums/viewthread/30708 but it didn't fix my problem.

    Any suggestions? Thanks.


  • Lifetime Qt Champion

    Hi,

    Are you starting your program from Qt creator ?

    If not, are you sure that all dependencies are found ?



  • Hi SGaist,

    Thanks for your reply.

    No, sorry, I am not using Qt creator, and I am using cmake, not qmake.

    It doesn't look like it can't find anything

    @$ ldd ../DR_install/ext/bin32/drgui
    linux-gate.so.1 => (0xf77d1000)
    libQt5Widgets.so.5 => /home/branden/Qt5.1.0/5.1.0/gcc/lib/libQt5Widgets.so.5 (0xf71a5000)
    libQt5Gui.so.5 => /home/branden/Qt5.1.0/5.1.0/gcc/lib/libQt5Gui.so.5 (0xf6d3a000)
    libQt5Core.so.5 => /home/branden/Qt5.1.0/5.1.0/gcc/lib/libQt5Core.so.5 (0xf68b8000)
    libstdc++.so.6 => /lib/libstdc++.so.6 (0xf67af000)
    libm.so.6 => /lib/libm.so.6 (0xf676b000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf674e000)
    libc.so.6 => /lib/libc.so.6 (0xf6591000)
    libpthread.so.0 => /lib/libpthread.so.0 (0xf6577000)
    libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0xf6527000)
    libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0xf63f4000)
    libX11.so.6 => /lib/libX11.so.6 (0xf62ba000)
    libGL.so.1 => /lib/libGL.so.1 (0xf6242000)
    libicui18n.so.51 => /home/branden/Qt5.1.0/5.1.0/gcc/lib/libicui18n.so.51 (0xf6020000)
    libicuuc.so.51 => /home/branden/Qt5.1.0/5.1.0/gcc/lib/libicuuc.so.51 (0xf5ea7000)
    libdl.so.2 => /lib/libdl.so.2 (0xf5ea2000)
    libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0xf5e9e000)
    librt.so.1 => /lib/librt.so.1 (0xf5e95000)
    /lib/ld-linux.so.2 (0xf77d2000)
    libffi.so.6 => /lib/libffi.so.6 (0xf5e8d000)
    libxcb.so.1 => /lib/libxcb.so.1 (0xf5e6b000)
    libglapi.so.0 => /lib/libglapi.so.0 (0xf5e2d000)
    libXext.so.6 => /lib/libXext.so.6 (0xf5e19000)
    libXdamage.so.1 => /lib/libXdamage.so.1 (0xf5e15000)
    libXfixes.so.3 => /lib/libXfixes.so.3 (0xf5e0f000)
    libX11-xcb.so.1 => /lib/libX11-xcb.so.1 (0xf5e0c000)
    libxcb-glx.so.0 => /lib/libxcb-glx.so.0 (0xf5df3000)
    libxcb-dri2.so.0 => /lib/libxcb-dri2.so.0 (0xf5ded000)
    libXxf86vm.so.1 => /lib/libXxf86vm.so.1 (0xf5de6000)
    libdrm.so.2 => /lib/libdrm.so.2 (0xf5dd9000)
    libselinux.so.1 => /lib/libselinux.so.1 (0xf5db6000)
    libicudata.so.51 => /home/branden/Qt5.1.0/5.1.0/gcc/lib/libicudata.so.51 (0xf486d000)
    libXau.so.6 => /lib/libXau.so.6 (0xf4869000)
    libpcre.so.1 => /lib/libpcre.so.1 (0xf4800000)@

    xcb is even listed on line 22 above
    @libxcb.so.1 => /lib/libxcb.so.1 (0xf5e6b000)@


  • Lifetime Qt Champion

    Seems right, can you run ldd on Qt's xcb plugin ?



  • ldd /home/branden/Qt5.1.0/5.1.0/gcc/plugins/platforms/libqxcb.so
    revealed
    libXi.so.6 => not found
    after installing the 32-bit version of libXi my application started.

    Thanks!


  • Lifetime Qt Champion

    You're welcome !

    Since everything is working now, don't forget to update the thread's title to solved so other forum users may know a solution has been found :)



  • Hi ,
    I am facing a similar issue could you please help.

    Got keys from plugin meta data ("xcb")
    QFactoryLoader::QFactoryLoader() checking directory path "/usr/bin/platforms" ...
    QFactoryLoader::QFactoryLoader() looking at "/usr/bin/platforms/libqeglfs.so"
    Got keys from plugin meta data ("eglfs")
    QFactoryLoader::QFactoryLoader() looking at "/usr/bin/platforms/libqlinuxfb.so"
    Got keys from plugin meta data ("linuxfb")
    QFactoryLoader::QFactoryLoader() looking at "/usr/bin/platforms/libqminimal.so"
    Got keys from plugin meta data ("minimal")
    QFactoryLoader::QFactoryLoader() looking at "/usr/bin/platforms/libqminimalegl.so"
    Got keys from plugin meta data ("minimalegl")
    QFactoryLoader::QFactoryLoader() looking at "/usr/bin/platforms/libqoffscreen.so"
    Got keys from plugin meta data ("offscreen")
    QFactoryLoader::QFactoryLoader() looking at "/usr/bin/platforms/libqvnc.so"
    Got keys from plugin meta data ("vnc")
    QFactoryLoader::QFactoryLoader() looking at "/usr/bin/platforms/libqxcb.so"
    Got keys from plugin meta data ("xcb")
    loaded library "/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so"

    qt.qpa.xcb: could not connect to display
    qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "/opt/appname/libs/Qt/plugins/platforms" even though it was found.
    This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

    Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb


  • Lifetime Qt Champion

    @jarvis there's no need to post the same questions on multiple threads especially on one that is 7 years old.



  • @SGaist My bad, I was trying to troubleshoot this issue referring to the past posts.


Log in to reply