Debug does not see changes



  • Hello everyone!

    I'm going crazy here. Everytime i have made the smallest change and want to debug, the debugger doesn't see the change. A clean doesn't work either. These are the steps i have to take for the debugger to see my changes:

    Remove debug directory

    Build

    Build with install argument

    qmake

    If i do not use these steps, it will just use the last succesfully compiled files. Another "funny" thing is, when i set a beakpoint in a new function and debug...it will just skip the breakpoint to a function which was already there before the new function. It's a ghost function untill i repeat the above steps...

    I am using:
    QtCreator 2.5.2
    Qt version 4.7.3
    GDB debugger: C:\python_2.7based\gdb-i686-pc-mingw32.exe


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What kind of project are you trying to debug ? App + static library ?


  • Moderators

    The sequence of your four statements is a bit strange. Certainly qmake shall be at first.

    My experience shows that complex projects do not always do the compiling at all times. I am using "subdirs" template with a couple of static libs and an application. In most cases changes are compiled and used in debugging. It is hard to give a scheme when the problems are. I expect when I change in at least one lib and the app at the same time, I get the problems.
    You are using an older creator version. Possibly updating will ease the problem, but not eliminate. Just a gut feeling.



  • I do have some static libraries in my project. But i am not using them in the classes i am editing at the moment. I tried the latest qt creator version, but my debugger crashes with that one...
    Which debugger are you guys using with QT Creator 2.8.0?

    The strange thing is...it always used to work. Then when i branched the project and worked in the branch this issue came up. The first build is good, then when you change a value from 1 to 2 and debug it, it will still see 1 and not 2.


  • Moderators

    The debugger has something to do with your compiler respectively the tool chain you are using. That should be independent from qt creator's version.
    If you have not changed or updated the tool chain and Qt libs version it should be as before.

    What did you do when branching your project?
    Probably I had to setup a new project configuration right at the beginning. May be something went wrong there.
    Also you might have gotten *.pro.user file from your repository which does not fit your current configuration.
    I would push the changes to the repository, when possible, and checkout again. Make sure that you are not retrieving an old *.pro.user file and set up properly the new configuration for the project in qt creator.
    Alternatively, you can probably close creator and delete the *.pro.user file. At start of qt creator for this project, you will a notification and have to setup the project with the tool chain.



  • I did not change anything in the toolchain. The only thing i did was branch my trunk...I copied the head revision to a branch...minus the .pro.user file.
    It always makes a fresh user file. I also tried to delete the user file and restart qt creator. The toolchain is exactly the same as the project that does still see the changes.

    Im at a loss here...still having to delete the whole directory :(


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.