Solved: Qt Creator doesn't debug a non-Qt project



  • Hello experts-

    I just started using Qt Creator in Ubuntu via a VM on Windows. I created a plain non-Qt C project using the Creator. When I tried to debug the project, I got an error message describing a prblem as below:

    "ptrace: Operation not permitted.

    Could not attach to the process. Make sure no other debugger traces this process.
    Check the settings of
    /proc/sys/kernel/yama/ptrace_scope
    For more details, see /etc/sysctl.d/10-ptrace.conf"

    The system environment is set as below:
    Native OS: Windows 7 (64 bit)
    UBuntu: 12.04
    Qt: 4.8.3 (64 bit)
    Creator: 2.6.2
    Compiler: GCC (x86 64 bit)
    Debugger: GDB 7.4-2012.04, configured as x86_64-linux-gnu

    The program was built and run properly without debugging mode.

    I look forward to any hints/ideas on how to fix the the problem.

    Thanks in advance.

    Jason



  • Just found that this is actually an issue of Qt Creator with Ubuntu of versions later than 10.10. Go https://bugreports.qt-project.org/browse/QTCREATORBUG-3509 to find a workaround to the problem.


  • Lifetime Qt Champion

    Thanks for sharing the info, could you also update the thread's title to solved ? So other users having the same problem will grab the workaround :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.