Qt 5.01 does not start on Red Hat Linux 6 or Oracle Linux



  • Hi,

    I have Red Hat Enterprise Linux 6 64-bit and I tried to install Qt 5.0.1 64-bit for Linux and it ran in to the following error:
    Failed to load core: /u02/app/Qt/Tools/QtCreator/lib/qtcreator/plugins/QtProject/libCore.so: Cannot load library /u02/app/Qt/Tools/QtCreator/lib/qtcreator/plugins/QtProject/libCore.so: (/usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /u02/app/Qt/Tools/QtCreator/lib/qtcreator/plugins/QtProject/../.././libQt5CLucene.so.5))

    The libstdc++.so.6 is the latest release that it can possibly be but it's latest GLIBCXX is GLIBCXX_3.4.13 and not GLIBCXX_3.4.15. I used strings on it and greped for GLIBCXX.

    I have tried setting LIBS and other environment variables but it has not worked. I have seen posts that suggest rebuilding/make gcc but I do not think that seems to be the issues.

    Thanks in advance!


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You either need to update your system to get a more recent version of libstdc++ or compile Qt yourself.

    You can search this forum for similar questions and get hints from these too


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.