[Closed] Unable to run Qt app on ARM linux with an /tmp and /dev/fb0 issues



  • My host system is Ubuntu-12.04 x86_64bit
    My target system is Pandaboard- ARMv7 Ubuntu-12.04
    My toolchain is arm-linux-gnueabihf-
    I configured Device type as Desktop in Qt Creator->Tools->Options

    I am successful in compiling Qt source on host system with qmake.conf as

    qmake configuration for building with arm-panda-g++

    include(../../common/linux.conf)
    include(../../common/gcc-base-unix.conf)
    include(../../common/g++-unix.conf)
    include(../../common/qws.conf)

    modifications to g++.conf

    QMAKE_CC = arm-linux-gnueabihf-gcc
    QMAKE_CXX = arm-linux-gnueabihf-g++
    QMAKE_LINK = arm-linux-gnueabihf-g++
    QMAKE_LINK_SHLIB = arm-linux-gnueabihf-g++

    modifications to linux.conf

    QMAKE_AR = arm-linux-gnueabihf-ar cqs
    QMAKE_OBJCOPY = arm-linux-gnueabihf-objcopy
    QMAKE_STRIP = arm-linux-gnueabihf-strip

    load(qt_config)

    and build Qt src with following configuration

    ./configure -opensource -confirm-license -prefix /opt/qt-panda-armhf -embedded arm -platform qws/linux-x86_64-g++ -xplatform qws/linux-panda-g++ -no-pch -little-endian

    After this i copied /opt/qt-panda-armhf/lib from host to the target with same location as /opt/qt-panda-armhf/lib.

    Then i built qt app in QtCreator , by setting qmake, after building qt source with above mentioned qmake.conf. and setting arm-linux-gnueabihf- g++ compiler.

    I am successful in building qt gui app in qtcreator and got executable file.

    Then i copied the executable onto pandaboard target board and run by exporting the /opt/qt-panda-armhf/lib

    run as
    $ ./my_app -qws

    But i am unable to run the app. with following issue
    Cannot create Qt for Embedded Linux data directory: /tmp/qtembedded-0

    < for this i tried by changing /tmp folder in qt src path to user directory
    But got the same error as
    Cannot create Qt for Embedded Linux data directory: ~/App/temp/qtembedded-0 >

    < even i tried with mount point in /etc/fstab as
    none /tmp/ tmpfs size=1M 0 0
    But in this case also iam unable to run

    One more issue i found when running app as
    $ ./my_app
    then i got the issue as QScreenLinuxFb::connect: No such file or directory
    Error opening frame buffer device /dev/fb0

    < for this i tried

    $ ./my_app -qws -display LinuxFb

    But i am unsuccessful>

    need help regarding the same...


  • Lifetime Qt Champion

    Hi, posting in one sub-forum is enough.

    Please don't multi-post.

    "Duplicate":http://qt-project.org/forums/viewthread/29897/


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.