Linux 64bit + x11 = nothing



  • Hi, if I try run any application that uses qt5,
    I don't see any window. While application itself is running,
    I see in debuger that event loops works, but no window at all.

    For example I run "designer", and I see under debuger 4 threads,
    "designer", "QXcbEventReader", "designer", "gdbus".
    Events loops hang in poll system call, so all looks good, but I can not find
    any window.

    I tried install qt5 with help of my package manger (portage, Gentoo) = nothing.
    I tried build from git, using instruction from site = nothing.
    I tried online installer from site = nothing.

    qt4 works fine, I have nvidia binary driver with opengl support,
    opengl also works fine.

    Any hints what is going wrong?

    PS I used qt 5.1



  • Ok, reply to myself. I bisect qt5,
    and find out that that faulty commit is:
    b5bdd31de Implement XEmbed protocol.

    I comment such lines:
    long data[] = { XEMBED_VERSION, XEMBED_MAPPED };
    Q_XCB_CALL(xcb_change_property(xcb_connection(), XCB_PROP_MODE_REPLACE, m_window,
    atom(QXcbAtom::_XEMBED_INFO),
    atom(QXcbAtom::_XEMBED_INFO),
    32, 2, (void *)data));
    and all start working.

    So my windows manager (icewm) and qt5 have diffrent thoughts about xembed protocol.


  • Lifetime Qt Champion

    Hi,

    It might be useful to discuss this issue on the mailing list, or fill a bug report about it.



  • Create bug report:

    https://bugreports.qt-project.org/browse/QTBUG-32269

    but it is possible to say that qt is not broken, the world is broken,
    so not sure that this problem will be solved.


  • Lifetime Qt Champion

    Adding a complete code sample to your bug-report would be useful. That would avoid the future assignee (or any contributor wanting to dig into this bug) to first find how to reproduce the problem.



  • What do you mean under complete code sample, can you explain?

    Any applications have no window. designer, assistant, qt creator, any from examples subdirectories.


  • Lifetime Qt Champion

    Sorry, my bad, I've missed one point when I read the bug report


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.