Cerdisp argument -c is not recognized by QProcess under WinCE



  • In my WinCE application it is designed to start cerdisp quietly in background after a button is clicked, which is connected to the following slot.

    @
    void networkDisplayServiceSlot::startRemoteService()
    {
    m->remoteServiceProcess = new QProcess();
    QString program = "\Windows\cerdisp.exe";
    QStringList arguments;
    arguments << "-c";
    m->remoteServiceProcess->start(program, arguments );
    }
    @

    m->remoteServiceProcess is declared as
    @
    QProcess * remoteServiceProcess;
    @

    The cerdisp version is 3.00 on my WinCE6.0 with ARM11 (MCIMX35).

    The invoke of the cerdisp is successful, but it is waiting there for the user to confirm by clicking the "Start" button. However, the application is running always on the top, so that the button confirmation in background is impossible. I need the cerdisp to be called up quietly without further user actions.
    It seems to me that the argument "-c" is not correctly transferred to cerdisp.

    I tried to excute the "cerdisp -c" command directly in the DOS window on the device, and it worked well, without poping up a window for confirmation, and then i could cerhost from another PC to make the remote control within the LAN.
    I also tried a similiar slot for another program under Win32, and the arguments were successfully accepted.

    Has anybody any idea, what i did wrong? Or how can i work around?
    Thanks!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.