[Qt 5.0.2] Build problems



  • Hi everyone.
    When I create a project and I build it I get this error:
    "MAKEFILE_GENERATOR variable not set as a result of parsing : myProject.pro. Possibly qmake was not able to find files included using "include(..)" - enable qmake debugging to investigate more."
    I am on Windows 7 64


  • Moderators

    Are you using Qt creator to create the project?



  • yes i'm using Qt Creator.


  • Lifetime Qt Champion

    Hi,

    Could you show your myProject.pro ?



  • This is my .pro file
    @
    #-------------------------------------------------

    Project created by QtCreator 2013-06-14T23:14:54

    #-------------------------------------------------

    QT += core gui

    greaterThan(QT_MAJOR_VERSION, 4): QT += widgets

    TARGET = sans_titre
    TEMPLATE = app

    SOURCES += main.cpp
    mainwindow.cpp

    HEADERS += mainwindow.h

    FORMS += mainwindow.ui

    @


  • Moderators

    -What OS are you on?- Just saw it is Windows 7.

    I have scanned all files on my Qt folder (it is Qt 4.8.4) for "MAKEFILE_GENERATOR". This is just a settings in mkspecs/*.conf files basically declaring the OS you are on. For most it simply states "UNIX".

    My guess is that there is a problem with the setup of Qt on your system. My recommendation is reinstall. Maybe someone else has a better idea.



  • Done but same problem


  • Lifetime Qt Champion

    What IDE are you using ?

    Did you try with the latest 5.1 ?



  • I just had thee very same errors when trying to build QtCreator 2.7.0 project when I entered the command qmake -r or somthing.

    What I did to resolve that issue was the following (not sure exactly which one cured it)

    1. Searched for where qmake was located (search your Qt install folder) and added that path to my %PATH%.

    2. Installed perl from: "perl":http://www.activestate.com/activeperl/downloads

    3. Installed GIT (I don't think you need to do this though).

    4. Finally (and I am also not sure you need this, but you do to build QtCreator) searched for "sh.exe" on my PC and checked if any of those locations were in my %PATH% and removed them.

    Probably step one is the most important I would think. Maybe you can just print your entire %PATH% variable to this post and we can take a look to see if there is anything obvious missing...

    Of course, this may or may not be your issue... but it looks really similar to mine.

    The other thing is: did you install Qt from the SDK (i.e. Qt SDK5.0.2) from here: "qt-sdk-5.0.2":http://qt-project.org/downloads
    ?

    that would be the easiest way to get the whole package up and running (and un-install anything you had before...



  • update: Actually I just noticed that I don't think Qt/Qt SDK add themselves to your PATH variable, I think they setup their paths "on the fly". So just note that : ) - if you do add this to your path and it works, then I would not recommend leaving it like that incase there are some conflicts with other programs. If that is the problem then there is more an issue with your "local" paths when running Qt/QMake...



  • @SGalst I am using Qt Creator and Mingw and I didn't already try Qt 5.1 because I could face the same problem.
    @code_fodder Yes



  • I don't know if it can be the problem origin: I also have Qt 4.8.1 installed in C harddisk and I want to install Qt 5.0.2 in E. Is it a problem?
    Another thing is in Options > Build and run>Qt Version under the Autodetected block I have " ! Qt 5.0.2 MinGW 32bit E:\Qt\5.0.2\mingw47_32\bin\qmake.exe". If you have not noticed, I have an exclamation mark before Qt 5.0.2 and the MinGW is 32 bits is it a problem because I am on Windows 7 64 bits?
    Thanks to all.


  • Moderators

    [quote author="irobot" date="1371914695"]If you have not noticed, I have an exclamation mark before Qt 5.0.2 and the MinGW is 32 bits is it a problem because I am on Windows 7 64 bits?
    [/quote]
    No problem using MinGW 32 bit version on Windows 64 bit. I have installed MinGW 4.6.2 32 bit on windows 7 64 bit without problems.

    [quote author="irobot" date="1371914695"]
    Another thing is in Options > Build and run>Qt Version under the Autodetected block I have " ! Qt 5.0.2 MinGW 32bit E:\Qt\5.0.2\mingw47_32\bin\qmake.exe". If you have not noticed, I have an exclamation mark before Qt 5.0.2.
    [/quote]
    The exclamation mark is probably displayed as an icon. IIRC it should give some explanations when you click on it.



  • No it's the yellow one not the red.


  • Lifetime Qt Champion

    Anyway, it should give you an hint on what is wrong when clicking on it. If not, ensure that the details panel is hidden.



  • Version name: Qt 5.0.2 MingW 32bit
    qmake location : C:\Qt\Qt5.0.2\5.0.2\mingw47_32\bin\qmake.exe
    qmlscene not installed
    qmlviewer not installed

    When I use the Qt 5.0.2 for Desktop prompt, I have :

    @
    Setting up environment for Qt usage...

    C:\Qt\Qt5.0.2\5.0.2\mingw47_32>cd E:\tepan2\Qt project\2

    C:\Qt\Qt5.0.2\5.0.2\mingw47_32>E:

    E:\tepan2\Qt project\2>qmake -project

    E:\tepan2\Qt project\2>mingw32-make
    mingw32-make: *** No targets specified and no makefile found. Stop.

    E:\tepan2\Qt project\2>qmake -d
    DEBUG 1: Resetting dir to: E:\tepan2\Qt project\2
    DEBUG 1: Changing dir to: E:\tepan2\Qt project\2
    DEBUG 1: visiting file C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/spec_pre.
    prf
    DEBUG 1: C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/spec_pre.prf: entering
    block
    DEBUG 1: C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/spec_pre.prf: leaving b
    lock, okey=true
    DEBUG 1: done visiting file C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/spec
    _pre.prf
    DEBUG 1: visiting file C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/win32-g++/qmake.co
    nf
    DEBUG 1: C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/win32-g++/qmake.conf: entering b
    lock
    DEBUG 1: C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/win32-g++/qmake.conf: leaving bl
    ock, okey=true
    DEBUG 1: done visiting file C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/win32-g++/qma
    ke.conf
    DEBUG 1: visiting file C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/spec_post
    .prf
    DEBUG 1: C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/spec_post.prf: entering
    block
    DEBUG 1: C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/spec_post.prf: leaving
    block, okey=true
    DEBUG 1: done visiting file C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/spec
    _post.prf
    DEBUG 1: visiting file C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/default_p
    re.prf
    DEBUG 1: C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/default_pre.prf: enteri
    ng block
    DEBUG 1: C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/default_pre.prf: leavin
    g block, okey=true
    DEBUG 1: done visiting file C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/defa
    ult_pre.prf
    DEBUG 1: visiting file E:/tepan2/Qt project/2/2.pro
    DEBUG 1: E:/tepan2/Qt project/2/2.pro: entering block
    DEBUG 1: E:/tepan2/Qt project/2/2.pro:5: TEMPLATE := subdirs
    DEBUG 1: E:/tepan2/Qt project/2/2.pro:8: SUBDIRS := 2.pro sans_titre
    DEBUG 1: E:/tepan2/Qt project/2/2.pro:8: leaving block, okey=true
    DEBUG 1: done visiting file E:/tepan2/Qt project/2/2.pro
    DEBUG 1: visiting file C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/default_p
    ost.prf
    DEBUG 1: C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/default_post.prf: enter
    ing block
    DEBUG 1: C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/default_post.prf: leavi
    ng block, okey=true
    DEBUG 1: done visiting file C:/Qt/Qt5.0.2/5.0.2/mingw47_32/mkspecs/features/defa
    ult_post.prf
    MAKEFILE_GENERATOR variable not set as a result of parsing : 2.pro. Possibly qma
    ke was not able to find files included using "include(..)" - enable qmake debugg
    ing to investigate more.

    E:\tepan2\Qt project\2>
    @


  • Lifetime Qt Champion

    Without the information provided when clicking on the exclamation mark icon, there's only the crystal ball solution or try to install your Qt on the C drive.



  • Sorry I said it in my last post:
    @
    Version name: Qt 5.0.2 MingW 32bit
    qmake location : C:\Qt\Qt5.0.2\5.0.2\mingw47_32\bin\qmake.exe
    qmlscene not installed
    qmlviewer not installed
    @
    And I already install it on my C drive.


  • Lifetime Qt Champion

    When I first read your last post it said "Other solutions ?"

    Anyway, unless you're doing qml projects, they are not vital to the development. Can you move your projects in a folder path without any spaces ?

    There have always been problems with handling spaces in path.



  • I moved it. Same problem.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.