[Solved] Installation of QT in RedHat linux



  • hi evry one,
    I have some problem regarding Installation of QT in Rhel

    at first i tried to install .run file but it is giving an error like

    bq. Floating point exception (core dumped)

    another one is tried to install .bin file it is giving an error like
    bq. ./qt-creator-linux-x86-opensource-2.7.1.bin: error while loading shared libraries: libgobject-2.0.so.0: cannot open shared object file: No such file or directory

    and finally I am tried to install tar.gz file it gives an error like g++ command will not found.

    My question is it possible to install qt in Redhat? if it is I want to know the procedure it is imaportant please help me from this problem


  • Moderators

    You need to install the dependencies of course. For the part about "installing" the tarball, see: "compiling Qt":http://qt-project.org/wiki/Building_Qt_5_from_Git. Or - surprise! - check out the README file.

    RHEL is always a bit problematic. I blame the "HELl" part of the name ;)


  • Lifetime Qt Champion

    Hi,

    You need to install the developer tools packages from RedHat (g++ and friends) if you want to build the sources.

    You will also need install the development packages for Qt's dependencies (i.e opengl)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.