[SOLVED] QtXml error in Android



  • I have started to develop an aplication that reads data from an XML file and when I try to deploy and start my app in the device it reports the following error:

    @Caused by: java.lang.UnsatisfiedLinkError: Cannot load library: link_image[1891]: 87 could not load needed library 'libQtXml.so' for 'libuntitled.so' (load_library[1093]: Library 'libQtXml.so' not found)@

    The device is a Nexus S with Ministro installed and with libraries downloaded. I have also tried to deploy the app with the option of use Qt local system libs in the device. I have found the libQtXml.so in my system where are also located QtCore and others. Should I modify the rules.xml to include QtXml? If this is the issue, which lines should I include?



  • Problem solved!!

    Looking at Google, finally I have found a solution, explained here: http://comments.gmane.org/gmane.comp.lib.qt.android/3490

    In the reply of May 9th of 2012 at 11:11 AlexDao says:

    bq. 1. Click button Project on left.

    1. Click tab Run setting
    2. Click to Package Configurations
    3. Click to tab Library
    4. Check QtNetwork
      Done.
      Have fun.

    It's really done!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.