Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

The error generate "No valid Qt Version found" in the Qt Creator 2.4.1 in Ubuntu 10.04



  • Hi,

    I install Qt Creator 2.4.1 by using following .bin file in Ubuntu 10.04, is this correct version or not for making GUI of AM3354??

    qt-creator-linux-x86-opensource-2.4.1.bin

    I RUN the Qt Creator IDE and setup Qt Creator to Configure qmake as per describe in Sitara Linux Training Hands on with QT. But when I create new project in Qt Creator the error generate "No valid Qt Version found" (in attached).

    Anybody kindly support for solve this problem.

    Regards,
    Dharmendra
    !C:\Documents and Settings\symco\Desktop\qt_error.png(123)!


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you install the Qt developer tools for your distribution ?



  • Hi, I working in Linux and I install the Qt creator 2.4.1 but i don't know which Qt developer tools require for its...

    So please suggest..

    Dharmendra


  • Lifetime Qt Champion

    @sudo apt-get install qt4-dev-tools@


  • Moderators

    What CPU is in an AM3354? I assume that it is a ARM based embedded system, please ignore the following paragraph if it is not:

    The Qt version you mention is for intel CPUs, so if this is an embedded ARM system, then you will need to cross-compile Qt yourself from the sources. You will also need a tool chain (compiler, etc.) to do so. This is usually provided by the company that does the embedded system?

    It might help if you did not use a link to your harddrive for the picture...



  • Thanks for sudden reply,,

    I got "qt4-dev-tools_4.6.2-0ubuntu5.6_i386.deb" from the Ubuntu website,,,, is this correct?

    I will try with it and give feedback..


  • Lifetime Qt Champion

    You're right, I overlooked that statement, it's a Texas Instrument ARM processor. So cross-compilation will be necessary. Generally I prefer to setup a completely working development environment for the host, then I add the embedded system related pieces.



  • AM3354 is Texas make Cortex A8 Microprocessor.



  • Hello Sir,

    Sorry for late,

    I installed ti-sdk-am335x-evm-05.06.00.00 SDK for development.

    I am using below mention environment setup for running Qt creator 2.4.1 and I was also running source the environment setup script (source linux-devkit/environment-setup) on terminal before run Qt creator and Also I run Qt creator 2.4.1 on same command line. I also install Qt creator in /home/rd/ path.

    So please look in this and give solution, Is there something missing in environment setup....?? or am I going in wrong direction?? Pls give the proper way to solve this problem.

    environemnt-setup file :

    SDK_PATH="/linux-devkit"
    if [ -z "$ZSH_NAME" ] && [ "x$0" = "x./environment-setup" ]; then
    echo "Error: This script needs to be sourced. Please run as ". ./environment-setup""
    exit 1
    else
    if [ -n "$BASH_SOURCE" ]; then
    SDK_PATH="dirname $BASH_SOURCE"
    fi
    SDK_PATH=readlink -f "$SDK_PATH"
    export SDK_PATH=/home/rd/ti-sdk-am335x-evm-05.06.00.00/linux-devkit
    fi
    export TOOLCHAIN_PATH=$SDK_PATH
    export TARGET_SYS=arm-arago-linux-gnueabi
    export PATH=$SDK_PATH/bin:$TOOLCHAIN_PATH/bin:$PATH
    export CPATH=$SDK_PATH/$TARGET_SYS/usr/include:$CPATH
    export LIBTOOL_SYSROOT_PATH=$SDK_PATH/$TARGET_SYS
    export PKG_CONFIG_SYSROOT_DIR=$SDK_PATH/$TARGET_SYS
    export PKG_CONFIG_PATH=$SDK_PATH/$TARGET_SYS/usr/lib/pkgconfig
    export CONFIG_SITE=$SDK_PATH/site-config
    alias opkg="LD_LIBRARY_PATH=$SDK_PATH/lib $SDK_PATH/bin/opkg-cl -f $SDK_PATH/etc/opkg-sdk.conf -o $SDK_PATH"
    alias opkg-target="LD_LIBRARY_PATH=$SDK_PATH/lib $SDK_PATH/bin/opkg-cl -f $SDK_PATH/$TARGET_SYS/etc/opkg.conf -o $SDK_PATH/$TARGET_SYS"
    export CC=arm-arago-linux-gnueabi-gcc
    export CPP="arm-arago-linux-gnueabi-gcc -E"
    export NM=arm-arago-linux-gnueabi-nm
    export RANLIB=arm-arago-linux-gnueabi-ranlib
    export OBJCOPY=arm-arago-linux-gnueabi-objcopy
    export STRIP=arm-arago-linux-gnueabi-strip
    export AS=arm-arago-linux-gnueabi-as
    export AR=arm-arago-linux-gnueabi-ar
    export OBJDUMP=arm-arago-linux-gnueabi-objdump
    export PKG_CONFIG_ALLOW_SYSTEM_LIBS=1
    export OE_QMAKE_CC=${TARGET_SYS}-gcc
    export OE_QMAKE_CXX=${TARGET_SYS}-g++
    export OE_QMAKE_LINK=${TARGET_SYS}-g++
    export OE_QMAKE_AR=${TARGET_SYS}-ar
    export OE_QMAKE_LIBDIR_QT=${SDK_PATH}/${TARGET_SYS}/usr/lib
    export OE_QMAKE_INCDIR_QT=${SDK_PATH}/${TARGET_SYS}/usr/include/qtopia
    export OE_QMAKE_MOC=${SDK_PATH}/bin/moc4
    export OE_QMAKE_UIC=${SDK_PATH}/bin/uic4
    export OE_QMAKE_UIC3=${SDK_PATH}/bin/uic34
    export OE_QMAKE_RCC=${SDK_PATH}/bin/rcc4
    export OE_QMAKE_QDBUSCPP2XML=${SDK_PATH}/bin/qdbuscpp2xml4
    export OE_QMAKE_QDBUSXML2CPP=${SDK_PATH}/bin/qdbusxml2cpp4
    export OE_QMAKE_QT_CONFIG=${SDK_PATH}/${TARGET_SYS}/usr/share/qtopia/mkspecs/qconfig.pri
    export QMAKESPEC=${SDK_PATH}/${TARGET_SYS}/usr/share/qtopia/mkspecs/linux-g++
    export OE_QMAKE_LDFLAGS="-L${SDK_PATH}/${TARGET_SYS}/usr/lib -Wl,-rpath-link,${SDK_PATH}/${TARGET_SYS}/usr/lib -Wl,-O1 -Wl,--hash-style=gnu"
    export OE_QMAKE_STRIP="echo"
    export PS1="[\e[32;1m][linux-devkit][\e[0m]:\w> "
    export PATH=/opt/compiler-path/bin:$PATH
    export ARCH=arm
    export CROSS_COMPILE=arm-arago-linux-gnueabi-

    So, please do needful.

    Regards,

    Dharmendra



  • Also I could not installed qt4-dev-tools, is this tool compulsory require?? so please suggest any link of its.

    Dharmendra


Log in to reply