[solved]Qt5.1beta1: Error when trying to compile program in android



  • Qt5.1beta1: Error when trying to compile program in android

    16:05:28: Running steps for project untitled1...
    16:05:28: Starting: "C:\Qt\Qt5.1.0beta1\5.1.0-beta1\android_armv7\bin\qmake.exe" C:\Qt\Qt5.1.0beta1\Tools\QtCreator\bin\untitled1\untitled1.pro -r -spec android-g++ "CONFIG+=debug" "CONFIG+=declarative_debug" "CONFIG+=qml_debug"
    16:05:32: The process "C:\Qt\Qt5.1.0beta1\5.1.0-beta1\android_armv7\bin\qmake.exe" exited normally.
    16:05:32: Starting: "ma-make.exe"
    qtcreator_ctrlc_stub: Command line failed: ma-make.exe
    16:05:32: The process "ma-make.exe" exited with code -1.
    Error while building/deploying project untitled1 (kit: android)
    When executing step 'Make'
    16:05:32: Elapsed time: 00:04.

    Someone knows how to solve?



  • I got the same problem, no clue where to look at, I even dont have ma-make.exe on my computer.
    I used qt-windows-opensource-5.1.0-beta1-android-x86-win32-offline-2013-05-14-32.exe
    available in http://download.qt-project.org/snapshots/qt/5.1/5.1.0-beta1/backups/

    @23:26:18: Running steps for project android-test...
    23:26:18: Configuration unchanged, skipping qmake step.
    23:26:18: Starting: "ma-make.exe"
    qtcreator_ctrlc_stub: Command line failed: ma-make.exe
    23:26:18: The process "ma-make.exe" exited with code -1.
    Error while building/deploying project android-test (kit: Android for arm (GCC 4.7, Qt 5.1.0))
    When executing step 'Make'
    23:26:18: Elapsed time: 00:00.@

    any idea ? :) Thank you



  • I will try to remove everything from the computer

    1-Uninstall all, including QtSDK and QtCreator
    2-Delete C: \ Users \ Flavio Portela \ AppData \ Roaming \ QtProject.
    3-Install only QtSDK5.1
    4- try new build de project for android.

    you also try and comment on the result that come together for a solution



  • Apparently, this build isn't really working even though it exists. If you want to build Android apps under windows you will have to wait a little more.



  • Indeed I tried to install it on another machine and the problem remains. That's a pitty, @utcenter when you say "wait a little more", does it mean wait until the official 5.1 version or do you mean that it's coming within the next days ?

    Thank you ;)



  • According to Tuukka Turunen android development on windows should be possible in the RC (release candidate) - so a little sooner than the final release as it seems.

    It does work on linux, or so I've been told, I just installed 5.1 beta on my ubuntu machine with the Android SDK and NDK but haven't had the time to test it out. Hopefully tomorrow.



  • Hi,

    Qt 5.1 beta uses mingW32.exe instead of ma-make tool. You can find it in the Qt5.1\tools\mingw32..
    Go to Project->make configuration. I think may be it is not installed with Qt 5.1 and you need to reinstall or click Maintenance Tool to install it.

    I think ma-make tool may be automatically detected from the environment variables.
    May be if the ma-make tool is not vaialable in your system, then delete the build folder and rebuild again.
    You can set the path to mingw32.exe (after the installation) in the Environment varaibles or can overrite the make tool in the Project configuration.
    Also for Android SDK, Qt prebuilt binaries is not successfull yet in windows, i think in Linux it works. But you can try Qt Necessitas (Qt 4.8 is the latest release) in Windows and it works well in Windows.

    Regards
    Ansif



  • Hi,

    I'm experiencing the same problem , on Linux (Fedora), when compiling an existing example (maroon) :

    @ 00:18:20: Veuillez patienter, recherche d'un périphérique approprié pour la cible : android-17.
    Erreur lors de la compilation/déploiement du projet maroon (kit : Android for x86 (GCC 4.4.3, Qt 5.1.0))
    Lors de l'exécution de l'étape "Déployer sur périphérique Android"@

    Which means : Error while building/deploying project maroon (kit : Android for x86 (GCC 4.4.3, Qt 5.1.0))

    I've followed "this guide":http://doc-snapshot.qt-project.org/qt5-stable/qtdoc/android-support.html. I've also tried to run the example on the different existing Kits for Android but i still get the same error !

    What's going wrong ?

    Thanks.



  • looks like a bug already known of the season, simply include the PATH and JAVAHOME MINGWDIR


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.